karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofre ...@nanthrax.net>
Subject Re: Karaf 4.2.9 Pax-Exam integration tests stopped working
Date Sat, 13 Jun 2020 05:05:18 GMT
Hi Alex,

SCR example is tested with Pax Exam on Karaf itself. However, not sure they are using ConfigurationPolicy.REQUIRE.
Let me try but I don’t see any reason why it would not work (no change on ConfigAdmin, but
I upgraded SCR version).

Let me check.

Regards
JB

> Le 12 juin 2020 à 22:12, Alex Soto <alex.soto@envieta.com> a écrit :
> 
> Hello,
> 
> I started migrating to Karaf 4.2.9 (from 4.2.8) and my integration tests are now all
failing. Some SCR components are never activated, specifically the ones with configurationPolicy
= ConfigurationPolicy.REQUIRE. However, if I run the application standalone, everything works
correctly, it is only when running with Pax-Exam that this happens.  Any idea?
> 
> Running with Pax-Exam version 4.13.2
> 
> Best regards,
> Alex soto
> 
> 
> 
> 


Mime
View raw message