karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: HTTP Session Clustering
Date Mon, 01 Apr 2019 13:57:10 GMT
Thanks for the update.

It could be related to the karaf xml spec we added in lib/endorsed.

Let me check and try to reproduce.

Regards
JB

On 01/04/2019 15:47, Oleg Cohen wrote:
> Hi JB,
> 
> Thank you for replying!
> 
> Karaf: 4.2.4
> JDK: 8u202
> 
> Standard distribution. I have a feature that has the required features
> in the doc listed as dependencies:
> 
> 
> <feature>http</feature>
> <feature>http-whiteboard</feature>
> 
> <feature>cellar</feature>
> 
> Thank you,
> Oleg
> 
> 
> 
> 
>> On Apr 1, 2019, at 9:40 AM, Jean-Baptiste Onofré <jb@nanthrax.net
>> <mailto:jb@nanthrax.net>> wrote:
>>
>> Hi Oleg,
>>
>> Is cellar feature installed correctly (providing the hazelcast instance) ?
>>
>> What Karaf version are you using ? Is it a custom distro ?
>>
>> Regards
>> JB
>>
>> On 01/04/2019 15:37, Oleg Cohen wrote:
>>> Greetings,
>>>
>>> I wonder if anybody ran into a similar issue. I followed the setup
>>> instructions
>>> here: https://karaf.apache.org/manual/cellar/latest-4/#_enable_cluster_http_session_replication
>>>
>>> Now that Karaf runs I am seeing this exception:
>>>
>>> 2019-04-01T09:31:09,489 | INFO  | .hazelcast-wm.ensureInstance |
>>> ClusteredSessionService          | 68 - com.hazelcast - 3.9.1 | Retrying
>>> the connection!!
>>> 2019-04-01T09:31:09,490 | INFO  | .hazelcast-wm.ensureInstance |
>>> HazelcastInstanceLoader          | 68 - com.hazelcast - 3.9.1 | Creating
>>> a new HazelcastInstance for session replication
>>> 2019-04-01T09:31:09,492 | WARN  | .hazelcast-wm.ensureInstance |
>>> ClusteredSessionService          | 68 - com.hazelcast - 3.9.1 | Cannot
>>> connect to Hazelcast server: XPathFactory#newInstance() failed to create
>>> an XPathFactory for the default object model:
>>> http://java.sun.com/jaxp/xpath/dom with the
>>> XPathFactoryConfigurationException: java.util.ServiceConfigurationError:
>>> javax.xml.xpath.XPathFactory: Provider
>>> org.apache.xpath.jaxp.XPathFactoryImpl not found
>>>
>>> I would appreciate suggestions on how to fix this.
>>>
>>> Thank you,
>>> Oleg
>>
>> -- 
>> Jean-Baptiste Onofré
>> jbonofre@apache.org <mailto:jbonofre@apache.org>
>> http://blog.nanthrax.net
>> Talend - http://www.talend.com
> 

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message