karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Karaf doesn't like Camel package with apache.commons.dbcp2
Date Fri, 02 Nov 2018 13:16:14 GMT
Hi John,

OK I think I narrowed your issue.

The pax-jdbc-pool-dbcp2 feature installs Commons DBCP 2.1.1 bundle.

However, your bundle seems to require at least DBCP 2.5.

So, I would propose to change your bundle headers to extend the range 
(something like [2,3)).

It's a bit surprising that your bundle directly depend on DBCP. It 
should use a datasource service.

Regards
JB

On 02/11/2018 14:09, John F. Berry wrote:
> Thanks JB for your patience,
> 
> OK.. what didn't I do about that from that list I did below.. Do I need to follow up
with another command than "feature:install pax-jdbc-pool-dbcp2"?
> 
> 
> On ‎Friday‎, ‎November‎ ‎2‎, ‎2018‎ ‎04‎:‎36‎:‎11‎ ‎AM‎
‎EDT, Jean-Baptiste Onofré <jb@nanthrax.net> wrote:
> 
> 
> Hi John,
> 
> You have to install the pax-jdbc-pool-dbcp2 feature. It should install
> the dbcp bundle for you.
> 
> I just have to check the version.
> 
> Regards
> JB
> 
> On 01/11/2018 18:14, John F. Berry wrote:
>> Thank you.
>> Installed the jdbc feature via the command
>> feature:install jdbc
>> Still getting the exact same error.
>>
>> On ‎Thursday‎, ‎November‎ ‎1‎, ‎2018‎ ‎12‎:‎44‎:‎34‎
‎PM‎ ‎EDT,
>> Jean-Baptiste Onofré <jb@nanthrax.net> wrote:
>>
>>
>> You need the dbcp bundle. You can install via jdbc feature.
>>
>> Regards
>> JB
>> Le 1 nov. 2018, à 20:19, bohnjerry <bohnjerry@yahoo.com
>> <mailto:bohnjerry@yahoo.com>> a écrit:
>>
>>      OK.. I've blown away my data folder again.. and the latest "rebuild" went
>>      like this:
>>
>>      feature:repo-add camel
>>      feature:install camel
>>      feature:install camel-core
>>      feature:install camel-hl7
>>      feature:install camel-sql
>>      feature:install pax-jdbc-pool-dbcp2
>>
>>      then
>>
>>      install -s mvn:org.ZZZ.camel/EDMtoPspft-java/1.0.0
>>
>>      and now I'm getting:
>>
>>      Unable to start bundle mvn:org.ZZZ.camel/EDMtoPsoft-java/1.0.0:
>>      org.osgi.framework.BundleException: Unable to resolve EDMtoPSoft-java [87](R
>>      87.0): missing requirement [EDMtoPSoft-java [87](R 87.0)]
>>      osgi.wiring.package;
>>      (&(osgi.wiring.package=org.apache.commons.dbcp2)(version>=2.5.0)(!(version>=3.0.0)))
>>      Unresolved requirements: [[EDMtoPSoft-java [87](R 87.0)]
>>      osgi.wiring.package;(&(osgi.wiring.package=org.apache.commons.dbcp2)(version>=2.5.0)(!(version>=3.0.0)))]
>>
>>      Did I miss a step?
>>
>>
>>
>>
>>      --
>>      Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
> 
>>
> 

Mime
View raw message