karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Karaf doesn't like Camel package with apache.commons.dbcp2
Date Fri, 02 Nov 2018 14:00:40 GMT
Same issue, your bundle still expect dbcp2 2.5. so you have to install this bundle version
or even better expand the version range.

Regards
JB

Le 2 nov. 2018 à 14:49, à 14:49, "John F. Berry" <bohnjerry@yahoo.com> a écrit:
>
>
>I was thinking perhaps I should just use another "package" that would
>still accommodate MSSQL calls so I could get by this issue.  
>
>Still not there.  Blew away Karaf data folder again (to eliminate my
>thrashing of configuration)
>
>karaf@root()> feature:repo-add camel
>Adding feature url
>mvn:org.apache.camel.karaf/apache-camel/RELEASE/xml/features
>karaf@root()> feature:install camel
>karaf@root()> feature:install camel-hl7
>karaf@root()> feature:install camel-core
>karaf@root()> feature:install camel-sql
>karaf@root()> feature:install pax-jdbc-pool-dbcp2
>karaf@root()> install -s mvn:org.ZZZ.camel/EDMtoPSoft-java/1.0.0Bundle
>ID: 97
>
>Error executing command: Error installing bundles:
>
>        Unable to start bundle mvn:org.ZZZ.camel/EDMtoPSoft-java/1.0.0:
>org.osgi.framework.BundleException: Unable to resolve EDMtoPSoft-java
>[97](R 97.0): missing rea [97](R 97.0)] osgi.wiring.package;
>(&(osgi.wiring.package=org.apache.commons.dbcp2)(version>=2.5.0)(!(version>=3.0.0)))
>Unresolved requirements: [[EDMtoPSoft-java [97](R
>97.(&(osgi.wiring.package=org.apache.commons.dbcp2)(version>=2.5.0)(!(version>=3.0.0)))]karaf@root()>
>My manifest file looks like this:
>
>Manifest-Version: 1.0
>Bnd-LastModified: 1541165408198
>Build-Jdk: 10.0.1
>Built-By: jberry
>Bundle-Activator: org.ZZZ.camel.Activator
>Bundle-ManifestVersion: 2
>Bundle-Name: EDM base64 HL7 documents to PeopleSoft
>Bundle-SymbolicName: EDMtoPSoft-java
>Bundle-Version: 1.0.0
>Created-By: Apache Maven Bundle Plugin
>Export-Package: org.ZZZ.camel;version="1.0.0";uses:="org.apache
> .camel.builder,org.osgi.framework"
>Import-Package:
>ca.uhn.hl7v2.model,ca.uhn.hl7v2.util,javax.sql,org.apach
> e.camel;version="[2.22,3)",org.apache.camel.builder;version="[2.22,3)",
> org.apache.camel.component.sql;version="[2.21,3)",org.apache.camel.impl
> ;version="[2.22,3)",org.apache.camel.main;version="[2.22,3)",org.apache
> .camel.model;version="[2.22,3)",org.apache.commons.dbcp2;version="[2,
> 3)",org.osgi.framework;version="[1.6,2)"
>Require-Capability: osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.8))"
>Tool: Bnd-3.5.0.201709291849
>
>
>
>
>On ‎Friday‎, ‎November‎ ‎2‎, ‎2018‎ ‎09‎:‎16‎:‎25‎ ‎AM‎
‎EDT,
>Jean-Baptiste Onofré <jb@nanthrax.net> wrote: 
>
>
>
>
>
>Hi John,
>
>OK I think I narrowed your issue.
>
>The pax-jdbc-pool-dbcp2 feature installs Commons DBCP 2.1.1 bundle.
>
>However, your bundle seems to require at least DBCP 2.5.
>
>So, I would propose to change your bundle headers to extend the range 
>(something like [2,3)).
>
>It's a bit surprising that your bundle directly depend on DBCP. It 
>should use a datasource service.
>
>Regards
>JB
>
>On 02/11/2018 14:09, John F. Berry wrote:
>> Thanks JB for your patience,
>> 
>> OK.. what didn't I do about that from that list I did below.. Do I
>need to follow up with another command than "feature:install
>pax-jdbc-pool-dbcp2"?
>> 
>> 
>> On ‎Friday‎, ‎November‎ ‎2‎, ‎2018‎ ‎04‎:‎36‎:‎11‎ ‎AM‎
‎EDT,
>Jean-Baptiste Onofré <jb@nanthrax.net> wrote:
>> 
>> 
>> Hi John,
>> 
>> You have to install the pax-jdbc-pool-dbcp2 feature. It should
>install
>> the dbcp bundle for you.
>> 
>> I just have to check the version.
>> 
>> Regards
>> JB
>> 
>> On 01/11/2018 18:14, John F. Berry wrote:
>>> Thank you.
>>> Installed the jdbc feature via the command
>>> feature:install jdbc
>>> Still getting the exact same error.
>>>
>>> On ‎Thursday‎, ‎November‎ ‎1‎, ‎2018‎ ‎12‎:‎44‎:‎34‎
‎PM‎ ‎EDT,
>>> Jean-Baptiste Onofré <jb@nanthrax.net> wrote:
>>>
>>>
>>> You need the dbcp bundle. You can install via jdbc feature.
>>>
>>> Regards
>>> JB
>>> Le 1 nov. 2018, à 20:19, bohnjerry <bohnjerry@yahoo.com
>>> <mailto:bohnjerry@yahoo.com>> a écrit:
>>>
>>>      OK.. I've blown away my data folder again.. and the latest
>"rebuild" went
>>>      like this:
>>>
>>>      feature:repo-add camel
>>>      feature:install camel
>>>      feature:install camel-core
>>>      feature:install camel-hl7
>>>      feature:install camel-sql
>>>      feature:install pax-jdbc-pool-dbcp2
>>>
>>>      then
>>>
>>>      install -s mvn:org.ZZZ.camel/EDMtoPspft-java/1.0.0
>>>
>>>      and now I'm getting:
>>>
>>>      Unable to start bundle mvn:org.ZZZ.camel/EDMtoPsoft-java/1.0.0:
>>>      org.osgi.framework.BundleException: Unable to resolve
>EDMtoPSoft-java [87](R
>>>      87.0): missing requirement [EDMtoPSoft-java [87](R 87.0)]
>>>      osgi.wiring.package;
>>>     
>(&(osgi.wiring.package=org.apache.commons.dbcp2)(version>=2.5.0)(!(version>=3.0.0)))
>>>      Unresolved requirements: [[EDMtoPSoft-java [87](R 87.0)]
>>>     
>osgi.wiring.package;(&(osgi.wiring.package=org.apache.commons.dbcp2)(version>=2.5.0)(!(version>=3.0.0)))]
>>>
>>>      Did I miss a step?
>>>
>>>
>>>
>>>
>>>      --
>>>      Sent from:
>http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
>> 
>>>
>> 

Mime
View raw message