karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Nodet <gno...@apache.org>
Subject Re: Confused about feature dependency="true"
Date Fri, 08 Dec 2017 12:55:29 GMT
You should have a line saying why javax.persistence/2.1.1.v201509150925 is
being refreshed.
Can you paste the whole output ?

Guillaume

2017-12-08 13:53 GMT+01:00 lechlukasz <l.lech@ringler.ch>:

> I think I've found the offender.
>
> The message says:
>
> org.glassfish.jersey.containers.jersey-container-servlet-core/2.22.2
> (Wired
> to javax.persistence/2.1.1.v201509150925 which is being refreshed)
>
> However, there's no indicator why it should be refreshed. The exact bundle
> is already installed in the system, in the exact the same version.
>
> The jersey-karaf-feature descriptor (that I've found somewhere in the
> internet, full of 'magic' numbers (start-levels) apparently needed to
> install jax-rs) refers the persistence bundle:
>
> <bundle
> start-level="50">mvn:org.eclipse.persistence/javax.
> persistence/2.1.1</bundle>
>
> however, that feature is already installed, and is using the
> 2.1.1.v201509150925 version.
>
> What can be the reason the bundle is wanted to be refreshed? how to find it
> out?
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
>



-- 
------------------------
Guillaume Nodet

Mime
View raw message