karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steinar Bang ...@dod.no>
Subject Re: Adding an @Activate to a DS bundle causes the bundle not to load
Date Sun, 10 Dec 2017 22:29:42 GMT
>>>>> Steinar Bang <sb@dod.no>:

>>> So for now I have the following plan:
>>> 1. Add the workaround stuff to my feature so that it will work with the
>>>    current version of the PostgreSQL JDBC driver

> This is now in place, and works:
>  https://github.com/steinarb/sonar-collector/commit/ceac58f468c11b4c86f516d1184c31f06c65e2bd

> Ie. the activate() method is called, and once I started using the fully
> qualified class name of the component as the configuration PID, the
> activate() method started receiving the correct configuration:
>  https://github.com/steinarb/sonar-collector#using-a-database-running-on-a-different-host

>>> 2. Open an issue for the the missing header in the PostgreSQL JDBC
>>>    driver issue tracker[3]

>> The issue is now in place:
>> https://github.com/pgjdbc/pgjdbc/issues/1029

>>> 3. Create a pull request with the appropriate maven-bundle-plugin
>>>    changes and send that to the maintainers

> This is still left to do.

The pull request is here:
 https://github.com/pgjdbc/pgjdbc-parent-poms/pull/10

Since the pull request was in a different github project than the one I
had opened an issue on, I also made a comment about the pull request on
the issue:
 https://github.com/pgjdbc/pgjdbc/issues/1029#issuecomment-350584909


Mime
View raw message