karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Carr <kscar...@gmail.com>
Subject Re: Weird Exception Karaf 4.1.3 on startup
Date Wed, 08 Nov 2017 12:56:18 GMT
It happens with both.  With .start it seems to start fine.  Then when I ssh
I get the issue.

With .karaf it is immediate due to the terminal opening with the command.

Seems to related to parse of history for the cli...

On Nov 8, 2017 2:14 AM, "Jean-Baptiste Onofré" <jb@nanthrax.net> wrote:

Hi Scott,

Good catch. So, it only happens with when you start karaf with ./start only
(not with ./karaf) ?
I could be related to the terminal settings. Let me try to reproduce.


On 11/08/2017 06:31 AM, Kevin Carr wrote:

> Anyone understand what this exception is for?
> I get this as soon as I run ./karaf with or without debug.  If I run
> ./start, it runs, but as soon as I try to connect via ssh it stops.
> Error executing command: For input string: "1502467344394"
> Exception in thread "Karaf local console user karaf"
> java.lang.IndexOutOfBoundsException: fromIndex = -1981
> at java.util.SubList.<init>(AbstractList.java:620)
> at java.util.AbstractList.subList(AbstractList.java:484)
> at org.jline.reader.impl.history.DefaultHistory.save(DefaultHis
> tory.java:123)
> at org.apache.karaf.shell.impl.console.ConsoleSessionImpl.close
> (ConsoleSessionImpl.java:283)
> at org.apache.karaf.shell.impl.console.ConsoleSessionImpl.run(
> ConsoleSessionImpl.java:380)
> at java.lang.Thread.run(Thread.java:748)
> Thanks
> --
> Scott Carr

Jean-Baptiste Onofré
Talend - http://www.talend.com

View raw message