karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Nodet <gno...@apache.org>
Subject Re: version resolving
Date Mon, 06 Nov 2017 13:12:24 GMT
This is not really a bug imho, but there's no way to specify better the
version range in maven.
In order to work around this behavior, you need to remove maven snapshot
repositories containing pax-cdi.  This way, it should not be resolved.

2017-11-06 13:53 GMT+01:00 Michal Hlavac <miso@hlavki.eu>:

> it means that there is bug in CXF, right?
>
>
>
> Because I can't build offline karaf distribution with cxf-3.2.0
>
> It searches for 1.0.0-SNAPSHOT on first start
>
>
>
> m.
>
>
> On pondelok, 6. novembra 2017 13:11:28 CET Guillaume Nodet wrote:
>
> Those version resolution are done by pax-url-aether which uses the aether
> library (the same one used by maven).
>
> I think the behavior is correct, see
>
>    https://cwiki.apache.org/confluence/display/MAVENOLD/
> Dependency+Mediation+and+Conflict+Resolution
>
>
> 2017-11-06 12:06 GMT+01:00 Michal Hlavac <miso@hlavki.eu>:
>
> Hi,
>
> I would like to ask about version resolving in repository element of
> feature file.
> I am asking because of line 21 in https://github.com/apache/cxf/
> blob/cxf-3.2.1/osgi/karaf/features/src/main/resources/features.xml
>
> <repository>mvn:org.ops4j.pax.cdi/pax-cdi-features/[1.0.0.
> RC1,2)/xml/features</repository>
>
> When I download karaf 4.1.3 and start it, then execute command:
> feature:list | grep pax-cdi
> output show version 1.0.0.RC2
>
> But after feature:repo-add cxf 3.2.0, then re-run feature:list | grep
> pax-cdi
> it shows additional 1.0.0-SNAPSHOT
>
> I suspect that karaf cannot resolve RCx version sufix
>
> thanks, m.
>
>
>
>
> --
>
> ------------------------
> Guillaume Nodet
>
>
>
>


-- 
------------------------
Guillaume Nodet

Mime
View raw message