karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KARR, DAVID" <dk0...@att.com>
Subject Need help resolving karaf 3.x dependency errors again
Date Tue, 07 Nov 2017 21:54:47 GMT
A month or so ago, I did some work on an app that runs in Karaf 3.x.  It took me quite a while
to figure out several dependency resolution issues, but I was able to get it working.  I've
since had my laptop reimaged, and now I have to do some more work in that app.  The reimaging
"restored" my data, but I'm finding some things didn't copy over exactly right.  My current
problem could be related to that, or it may be something else that I'm forgetting.

When I try to install my service, it installs a bunch of dependencies, and then fails with
this:

----------------
Error executing command: Can't install feature onemap-service/0.0.0:
Could not start bundle mvn:org.springframework/org.springframework.web/3.2.4.RELEASE in feature(s)
common-spring-jdbc-1.1.0-SNAPSHOT: Unresolved constraint in bundle org.springframework.web
[71]: Unable to resolve 71.0: missing requirement [71.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.aop.framework)(version>=3.2.4.RELEASE)(version<=3.2.4.RELEASE))
----------------

Very little is changed in the code since I last worked on it (no changes to dependencies),
so I don't know why this might be happening now.

This is the definition of the "common-spring-jdbc" feature:
---------------
    <feature name='common-spring-jdbc' version='1.1.0-SNAPSHOT' resolver='(obr)'>
        <bundle>mvn:org.springframework/org.springframework.web/3.2.4.RELEASE</bundle>
        <bundle>mvn:org.springframework/org.springframework.jdbc/3.2.4.RELEASE</bundle>
        <bundle>mvn:org.springframework.ws/spring-xml/2.1.4.RELEASE</bundle>
    </feature>
---------------

I tried doing "bundle:tree-show org.springframework.web".  This printed a bunch of "import"
lines, including the following one:
------------
- import org.springframework.aop.framework;version="[3.2.4.RELEASE, 3.2.4.RELEASE]": WARNING
- unable to find matching export
------------

At the end of this output, it printed the tree of dependencies of org.springframework.web,
but the tree did not include org.springframework.aop.framework.

What are some possible resolutions to this?

Mime
View raw message