karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Lichtin <lich...@yahoo.com>
Subject Re: Re: Nwe version 4.0.10 - instance:create/start not working
Date Fri, 29 Sep 2017 18:59:58 GMT
Right.. looks like my problem is that I've so far used the "-b" (bare) option.

This option behaves differently with 4.0.10 (or say, more correctly). So I'm no longer using
it.
Without this option, however, I need to nudge 'org.apache.karaf.features.cfg' so the extra
test features (all this runs in a Pax-Exam test) don't propagate to the instance.

Can confirm, 4.0.10 works fine :)

On 27.09.2017 19:01, Jean-Baptiste Onofré wrote:
> Some files are missing in the instance etc folder but it doesn't block the startup.
>
> Regards
> JB
>
> On 09/27/2017 07:00 PM, Jean-Baptiste Onofré wrote:
>> Hi Martin,
>>
>> I just tested on my machine without problem:
>>
>> karaf@root()> info
>> Karaf
>>    Karaf version               4.0.10
>> ...
>> karaf@root()> instance:create foobar
>> karaf@root()> instance:list
>> ...
>>      8103 |  0.0.0.0 |         1101 |           0.0.0.0 |
44446 | 0.0.0.0 | Stopped | 0     | foobar
>> karaf@root()> instance:start foobar
>> ....
>>      8103 |  0.0.0.0 |         1101 |           0.0.0.0 |
44446 | 0.0.0.0 | Started | 17002 | foobar
>>
>> Are you on Windows or Linux ?
>>
>> I checked and etc seems OK.
>>
>> Regards
>> JB
>>
>> On 09/27/2017 06:54 PM, Martin Lichtin wrote:
>>> Wanted to ask if the "instance" feature is working for anyone in 4.0.10? It no
longer does for me.
>>> It seems the instance:create is not populating 'etc' with all the necessary files.
>>
>


.

Mime
View raw message