karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KARR, DAVID" <dk0...@att.com>
Subject RE: Help interpreting error in "feature:install"
Date Fri, 29 Sep 2017 15:29:11 GMT
Ok, interesting.  The value of “org.ops4j.pax.url.mvn.repositories” in that file definitely
seems corrupted.  It appears that my repeated calls to “config:property-append” when I
start up karaf have been corrupting that.  It didn’t occur to me that the commands entered
into the karaf console after startup were persistent, and accumulating.  In retrospect, seeing
that it’s in the “config” domain, I should have realized it had been storing that setting.

Now that I understand that this command was only intended to be run once, not every time I
start up karaf, I edited the file so that the last comma-separated value was a valid repo
url, restarting karaf and installing my service completed successfully.

From: Guillaume Nodet [mailto:gnodet@apache.org]
Sent: Thursday, September 28, 2017 9:46 PM
To: user <user@karaf.apache.org>
Subject: Re: Help interpreting error in "feature:install"

When I see
file:C:/Users/<username>/frameworks/apache-karaf-3.0.1/data/kar@multihttp://<nexushostport>/nexus/content/groups/digitalexp/http://<<https://urldefense.proofpoint.com/v2/url?u=http-3A__-253C&d=DwQFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OsTemSXEn-xy2uk0vYF_EA&m=6T7JJJtgdpjNqmT3TJNu3DqFxuOyzjFhNncB-j2mdLI&s=cV0pETpOhX9lZDmGrWPNGIx85ZwxOm_aiGrialPdjmg&e=>nexushostport>/nexus/content/groups/digitalexp/
that makes me think you have some missing commas in your maven configuration.
Could you check your etc/org.ops4j.pax.url.mvn.cfg file ?

2017-09-28 21:15 GMT+02:00 KARR, DAVID <dk068x@att.com<mailto:dk068x@att.com>>:
After I determined that I have to run karaf 3.0.1 with Java 7, I'm now blocked trying to install
a feature.  I'm having trouble fully understanding exactly what is wrong.

I added the following lines to "bin/setenv.bat":
-------
set KARAF_OPTS=-Dhttp.useProxy=true -Dhttp.proxyHost=<proxyhostname> -Dhttp.proxyPort=8080
set JAVA_MAX_MEM=3572M
------------

After starting karaf, the instructions I have say to enter the following approximate commands:
-------------------
config:property-append -p  org.ops4j.pax.url.mvn org.ops4j.pax.url.mvn.repositories http://<nexushostport>/nexus/<https://urldefense.proofpoint.com/v2/url?u=http-3A__-253Cnexushostport-253E_nexus_&d=DwQFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OsTemSXEn-xy2uk0vYF_EA&m=6T7JJJtgdpjNqmT3TJNu3DqFxuOyzjFhNncB-j2mdLI&s=JzEvkC3sATFy4AUv7vvgHHL95z8bJMEv_Sf8unxlFmw&e=>content/groups/<groupname>/
feature:repo-add mvn:<groupid>/<artifact>/1.4.1-SNAPSHOT/xml/features
feature:install -v -c <name>-service
---------------------

I've elided some of this with "<>" placeholders.

When I run this, the last command fails with this:
------------------
Error executing command: Error resolving artifact <group>:common-features:xml:features:1.1.0-SNAPSHOT:
Could not transfer artifact <group>:common-features:xml:features:1.1.0-SNAPSHOT from/to
kar.repository (file:C:/Users/<username>/frameworks/apache-karaf-3.0.1/data/kar@multihttp://<nexushostport>/nexus/content/groups/digitalexp/http://<<https://urldefense.proofpoint.com/v2/url?u=http-3A__-253C&d=DwQFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OsTemSXEn-xy2uk0vYF_EA&m=6T7JJJtgdpjNqmT3TJNu3DqFxuOyzjFhNncB-j2mdLI&s=cV0pETpOhX9lZDmGrWPNGIx85ZwxOm_aiGrialPdjmg&e=>nexushostport>/nexus/content/groups/digitalexp/):
Repository path C:\Users\<username>\frameworks\apache-karaf-3.0.1\data\kar@multihttp:\<nexushostport>\nexus\content\groups\<groupname>\http:\<nexushostport>\nexus\content\groups\<groupname>does
not exist, and cannot be created.
------------------

Now, I note that when I run my local build, it builds version "1.1.20-SNAPSHOT of the "common-features"
artifact.  I looked on our nexus host, and the group does exist, and that artifact and version
(1.1.0-SNAPSHOT) does appear to be present.

I'm trying to understand at least what this error is actually complaining about, and perhaps
that will lead to a solution.



--
------------------------
Guillaume Nodet

Mime
View raw message