karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "KARR, DAVID" <dk0...@att.com>
Subject Help interpreting error in "feature:install"
Date Thu, 28 Sep 2017 19:15:54 GMT
After I determined that I have to run karaf 3.0.1 with Java 7, I'm now blocked trying to install
a feature.  I'm having trouble fully understanding exactly what is wrong.

I added the following lines to "bin/setenv.bat":
-------
set KARAF_OPTS=-Dhttp.useProxy=true -Dhttp.proxyHost=<proxyhostname> -Dhttp.proxyPort=8080
set JAVA_MAX_MEM=3572M
------------

After starting karaf, the instructions I have say to enter the following approximate commands:
-------------------
config:property-append -p  org.ops4j.pax.url.mvn org.ops4j.pax.url.mvn.repositories http://<nexushostport>/nexus/content/groups/<groupname>/
feature:repo-add mvn:<groupid>/<artifact>/1.4.1-SNAPSHOT/xml/features
feature:install -v -c <name>-service
---------------------

I've elided some of this with "<>" placeholders.

When I run this, the last command fails with this:
------------------
Error executing command: Error resolving artifact <group>:common-features:xml:features:1.1.0-SNAPSHOT:
Could not transfer artifact <group>:common-features:xml:features:1.1.0-SNAPSHOT from/to
kar.repository (file:C:/Users/<username>/frameworks/apache-karaf-3.0.1/data/kar@multihttp://<nexushostport>/nexus/content/groups/digitalexp/http://<nexushostport>/nexus/content/groups/digitalexp/):
Repository path C:\Users\<username>\frameworks\apache-karaf-3.0.1\data\kar@multihttp:\<nexushostport>\nexus\content\groups\<groupname>\http:\<nexushostport>\nexus\content\groups\<groupname>does
not exist, and cannot be created.
------------------

Now, I note that when I run my local build, it builds version "1.1.20-SNAPSHOT of the "common-features"
artifact.  I looked on our nexus host, and the group does exist, and that artifact and version
(1.1.0-SNAPSHOT) does appear to be present.

I'm trying to understand at least what this error is actually complaining about, and perhaps
that will lead to a solution.


Mime
View raw message