karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Karaf Cave installation failed in karaf-4.1.2
Date Fri, 18 Aug 2017 06:01:11 GMT
Hi

I didn't yet updated for 4.1.x. I will when back from vacation.

Regards
JB

On Aug 17, 2017, 22:10, at 22:10, Steinar Bang <sb@dod.no> wrote:
>I tried to follow the instructions in 
>https://karaf.apache.org/manual/cave/latest-4/#_pre_installation_requirements
>https://karaf.apache.org/manual/cave/latest-4/#_starting_apache_karaf_cave_server
>
>But the installation failed:
> karaf@root()> feature:repo-add cave 4.0.0
>Adding feature url
>mvn:org.apache.karaf.cave/apache-karaf-cave/4.0.0/xml/features
> karaf@root()> feature:install cave-server
>Error executing command: Unable to resolve
>org.eclipse.jetty.util/9.3.14.v20161028: missing requirement
>[org.eclipse.jetty.util/9.3.14.v20161028] osgi.wiring.package;
>filter:="(&(osgi.wiring.package=javax.servlet)(version>=2.6.0)(!(version>=3.2.0)))"
> karaf@root()> 
>
>The documentation for the latest version of cave says that it works on
>karaf 4.0.x.
>https://karaf.apache.org/manual/cave/latest-4/#_pre_installation_requirements
>
>Does this means that the lateset version of cave doesn't work on karaf
>4.1.2?
>
>Will cave master HEAD work on karaf 4.1.2?
>
>Thanks!
>
>
>- Steinar

Mime
View raw message