karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steinar Bang ...@dod.no>
Subject pax exam karaf not starting (Was: How to get the karaf.log logging in a pax exam test with the karaf container?)
Date Fri, 07 Jul 2017 10:21:02 GMT
>>>>> Steinar Bang <sb@dod.no>:

[snip!]
> Then the resulting karaf.log file ended up as
>  target/exam/<uuid>/data/log/karaf.log

> And in that file I found the reason why the integration test won't
> work: karaf shuts down.  Perhaps it is a variant of my old friend
> KARAF-5174?
>  https://issues.apache.org/jira/browse/KARAF-5174

> Now I know why it fails in the pax exam test and not in the regular
> karaf container (which was a bit of a mystery).  It actually fails in
> the regular karaf container the first time the ukelonn feature is
> installed, but when I restart the karaf container everything is
> normal.

> With the pax exam tests every time is the first time, because it
> creates a new environment for each run.

I think my pax exam (and regular karaf first-time) startup problem is
something other than KARAF-5174, because the two usual workarounds,
ie. throwing out the OSGi fragment version of liquibase-slf4j or
downgrading to karaf 4.0.x didn't work.

Throwing out the OSGi fragment version of liquibase-slf4j with karaf
4.1.1 gave the same behaviour as having the OGSGi fragmen present.

And swapping karaf 4.1.1 to 4.0.9 caused the features not to start at
all (everything was built from scratch with against karaf 4.0.9, but it
may be that I should have downgraded mare than the karaf version...?).


Mime
View raw message