karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Magon <pma...@gmail.com>
Subject Problems creating instances in 4.1.1
Date Mon, 15 May 2017 15:55:57 GMT
Hello,

I have several problems creating a new karaf instance (using jdk8 on
linux):
> instance:create node1
> instance:start node1

PROBLEM 1
-----------------

I get many warnings like these when starting the new instance:

2017-05-15T15:19:52,077 | WARN  | pool-2-thread-2  | AetherBasedResolver
           | 4 - org.ops4j.pax.url.mvn - 2.5.2 | Error resolving artifact
org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT: [Could
not find artifact
org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT
in apache (http://repository.apache.org/content/groups/snapshots-group/),
Could not find artifact org.apache.karaf.features:
enterprise:xml:features:4.1.1-SNAPSHOT in sonatype.snapshots.deploy (
https://oss.sonatype.org/content/repositories/snapshots/), Could not find
artifact org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT
in ops4j.sonatype.snapshots.deploy (https://oss.sonatype.org/
content/repositories/ops4j-snapshots/)]
java.io.IOException: Error resolving artifact org.apache.karaf.features:
enterprise:xml:features:4.1.1-SNAPSHOT: [Could not find artifact
org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT in apache (
http://repository.apache.org/content/groups/snapshots-group/), Could not
find artifact org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT
in sonatype.snapshots.deploy (https://oss.sonatype.org/content/repositories/
snapshots/), Could not find artifact org.apache.karaf.features:
enterprise:xml:features:4.1.1-SNAPSHOT in ops4j.sonatype.snapshots.deploy (
https://oss.sonatype.org/content/repositories/ops4j-snapshots/)]
...


It seems that the newly created instance still contains references on
SNAPSHOT version ( 4.1.1-SNAPSHOT):
.../instances/node1/etc/distribution.info
.../instances/node1/etc/config.properties

By removing references on "4.1.1-SNAPSHOT", I dont get these warnings...


PROBLEM 2
-----------------
I get many:
java.lang.NoClassDefFoundError: javax/annotation/Priority
        at org.apache.cxf.jaxrs.utils.AnnotationUtils.getBindingPriority(AnnotationUtils.java:85)
~[?:?]
...

I can fix this issue by using version 1.0 of javax.annotation instead of
1.2 in the file

.../instances/node1/etc/config.properties

PROBLEM 3
------------------
karaf@root()> instance:connect node1
Connecting to host localhost on port 8107
Connecting to unknown server. Automatically adding to known hosts.
Storing the server key in known_hosts.
Password:  *****

I dont get the shell on node1 instance (it is just getting stuck here...)
In the logs, I see:
[2017-05-15T15:55:45,586][INFO ][][ServerUserAuthService           ]
Session karaf@/127.0.0.1:42630 authenticated

a CTRL+D give me
karaf@root()>
Error executing command: java.io.IOException: Pipe closed
pmg@wspmg:

However, "ssh -p 8107 karaf@localhost" work perfecty...


PROBLEM 4 (or question)
------------------------------------

I was used to the behavior in 4.0.8 to use ctrl+C in the shell (to cancel
what I just typed...)
In 4.1.1, It exits the shell...
Is this a new behavior or a bug ??


Should I create Jira issue for those problems or there are already
identified ?

Thanks a lot for your support.

Regards,

Mime
View raw message