karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens Reimann <jreim...@redhat.com>
Subject Problem with bundle dependency, version range
Date Tue, 23 May 2017 13:02:07 GMT
Hi,

I am currently trying to write together a feature repository for using with
Karaf, I have the following feature:

---
    <feature name="my-feature" version="${project.version}">
        <bundle>mvn:${project.groupId}/my-bundle/${project.version}</bundle>

        <bundle
dependency="true">mvn:org.eclipse.paho/org.eclipse.paho.client.mqttv3/1.1.1</bundle>
    </feature>
---

Now I do have a dependency on Paho 1.0.2 (in the MANIFEST.MF), but I do
want to install Paho 1.1.1, when no other version of Paho is already
installed.

However if there already is e.g. Paho 1.0.2 installed or if only version
1.0.2 is available for installation, I would want to work with that version
instead.

Currently declaring the dependency above causes Karaf to always complain
that version 1.1.1 is not available even though version 1.0.2 is available.
Declaring a version range "[1,2)" for Paho makes it complain that an upper
version cannot be evaluated.

Any ideas?

Thanks for your help

Jens

-- 
Jens Reimann
Senior Software Engineer / EMEA ENG Middleware
Werner-von-Siemens-Ring 14
85630 Grasbrunn
Germany
phone: +49 89 2050 71286
_____________________________________________________________________________

Red Hat GmbH, www.de.redhat.com,
Registered seat: Grasbrunn, Commercial register: Amtsgericht Muenchen, HRB
153243,
Managing Directors: Paul Argiry, Charles Cachera, Michael Cunningham,
Michael O'Neill

Mime
View raw message