karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lichtin <lich...@yahoo.com>
Subject Re: Problems creating instances in 4.1.1
Date Sat, 27 May 2017 20:04:09 GMT
Hi, same SNAPSHOT issue also exists in 4.0.9, hope it will be fixed for
4.0.10.

https://issues.apache.org/jira/browse/KARAF-5018?focusedCommentId=16027576&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16027576


Hi,

thanks, let me try to reproduce it this morning and fix for 4.1.2.

Regards
JB

On 05/16/2017 10:22 AM, Patrick Magon wrote:
> Hello,
>
> I'm using 4.1.1...
>
> On Tue, May 16, 2017 at 1:15 AM, Jean-Baptiste Onofré &lt;jb@
&gt; &lt;mailto:jb@&gt;> wrote:
>
>     Hi Patrick,
>
>     Are you using 4.1.1-SNAPSHOT or released 4.1.1 version ?
>
>     Just before 4.1.1 release, I fixed couple of issues on instances
> (KARAF-4996
>     and KARAF-5018).
>
>     Regards
>     JB
>
>     On 05/15/2017 05:55 PM, Patrick Magon wrote:
>
>         Hello,
>
>         I have several problems creating a new karaf instance (using jdk8
> on linux):
>
>             instance:create node1
>             instance:start node1
>
>
>         PROBLEM 1
>         -----------------
>
>         I get many warnings like these when starting the new instance:
>
>         2017-05-15T15:19:52,077 | WARN  | pool-2-thread-2  |
> AetherBasedResolver
>              | 4 - org.ops4j.pax.url.mvn - 2.5.2 | Error resolving
> artifact
>         org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT:
> [Could not
>         find artifact
>         org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT
>         in apache
> (http://repository.apache.org/content/groups/snapshots-group/
>        
> &lt;http://repository.apache.org/content/groups/snapshots-group/&gt;
>         &lt;http://repository.apache.org/content/groups/snapshots-group/
&gt;        
&lt;http://repository.apache.org/content/groups/snapshots-group/&gt;>),
Could
>         not find
>         artifact
> org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT in
>         sonatype.snapshots.deploy
>         (https://oss.sonatype.org/content/repositories/snapshots/
>         &lt;https://oss.sonatype.org/content/repositories/snapshots/&gt;
>         &lt;https://oss.sonatype.org/content/repositories/snapshots/
&gt;        
&lt;https://oss.sonatype.org/content/repositories/snapshots/&gt;>), Could
not find
>         artifact
> org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT in
>         ops4j.sonatype.snapshots.deploy
>         (https://oss.sonatype.org/content/repositories/ops4j-snapshots/
>        
> &lt;https://oss.sonatype.org/content/repositories/ops4j-snapshots/&gt;
>         &lt;https://oss.sonatype.org/content/repositories/ops4j-snapshots/
&gt;        
&lt;https://oss.sonatype.org/content/repositories/ops4j-snapshots/&gt;>)]
>         java.io.IOException: Error resolving artifact
>         org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT:
> [Could not
>         find artifact
>         org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT
>         in apache
> (http://repository.apache.org/content/groups/snapshots-group/
>        
> &lt;http://repository.apache.org/content/groups/snapshots-group/&gt;
>         &lt;http://repository.apache.org/content/groups/snapshots-group/
&gt;        
&lt;http://repository.apache.org/content/groups/snapshots-group/&gt;>),
Could
>         not find
>         artifact
> org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT in
>         sonatype.snapshots.deploy
>         (https://oss.sonatype.org/content/repositories/snapshots/
>         &lt;https://oss.sonatype.org/content/repositories/snapshots/&gt;
>         &lt;https://oss.sonatype.org/content/repositories/snapshots/
&gt;        
&lt;https://oss.sonatype.org/content/repositories/snapshots/&gt;>), Could
not find
>         artifact
> org.apache.karaf.features:enterprise:xml:features:4.1.1-SNAPSHOT in
>         ops4j.sonatype.snapshots.deploy
>         (https://oss.sonatype.org/content/repositories/ops4j-snapshots/
>        
> &lt;https://oss.sonatype.org/content/repositories/ops4j-snapshots/&gt;
>         &lt;https://oss.sonatype.org/content/repositories/ops4j-snapshots/
&gt;        
&lt;https://oss.sonatype.org/content/repositories/ops4j-snapshots/&gt;>)]
>         ...
>
>
>         It seems that the newly created instance still contains references
> on
>         SNAPSHOT
>         version ( 4.1.1-SNAPSHOT):
>         .../instances/node1/etc/distribution.info
> &lt;http://distribution.info&gt;
>         &lt;http://distribution.info/&gt;
>         .../instances/node1/etc/config.properties
>
>         By removing references on "4.1.1-SNAPSHOT", I dont get these
> warnings...





--
View this message in context: http://karaf.922171.n3.nabble.com/Problems-creating-instances-in-4-1-1-tp4050359p4050476.html
Sent from the Karaf - User mailing list archive at Nabble.com.

Mime
View raw message