karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dario Amiri <dariusham...@hotmail.com>
Subject Conflicting versions of org.ow2.asm/asm-all
Date Tue, 06 Dec 2016 02:49:28 GMT
I'm seeing errors like this when starting 4.1.0-SNAPSHOT

2016-12-05T18:23:57,843 | ERROR | FelixStartLevel  | 
Felix                            |  -  -  | Bundle org.objectweb.asm.all 
[54] Error locking mvn:org.ow2.asm/asm-all/6.0_ALPHA 
(java.lang.IllegalStateException: Bundle in unexpected state.)
java.lang.IllegalStateException: Bundle in unexpected state.
     at 
org.apache.felix.framework.Felix.acquireBundleLock(Felix.java:5272) [?:?]
     at 
org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1524) [?:?]
     at 
org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:338) 
[?:?]
     at java.lang.Thread.run(Thread.java:745) [?:?]
2016-12-05T18:23:57,844 | INFO  | CM Configuration Updater 
(ManagedService Update: pid=[org.apache.cxf.osgi]) | 
TldScanner                       | 189 - org.ops4j.pax.web.pax-web-jsp - 
4.4.0 | found TLD bundle://189.0:0/META-INF/c.tld
2016-12-05T18:23:57,841 | ERROR | FelixDispatchQueue | 
all                              | 184 - org.objectweb.asm.all - 5.0.2 | 
FrameworkEvent ERROR - org.objectweb.asm.all
java.lang.IllegalStateException: Bundle in unexpected state.
     at 
org.apache.felix.framework.Felix.acquireBundleLock(Felix.java:5272) [?:?]
     at 
org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1524) [?:?]
     at 
org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:338) 
[?:?]
     at java.lang.Thread.run(Thread.java:745) [?:?]

Digging around a bit I can see that there are conflicting versions of 
org.ow2.asm/asm-all between the aries-blueprint feature version 
4.1.0-SNAPSHOT, which brings in aries-proxy which requires 
org.ow2.asm/asm-all/6.0_ALPHA, and pax-http feature version 4.4.0, which 
brings in pax-http-jetty which requires org.ow2.asm/asm-all/5.0.2. I'm 
not sure if this is what is causing the error in the logs.

One other thing worth noting is that my bundle list only shows 
org.ow2.asm/asm-all/5.0.2 loaded but org.ow2.asm/asm-all/6.0_ALPHA is in 
the system directory of the container and I am perfectly able to load it 
manually after the container loads. I would welcome any input on how to 
resolve this issue.

Mime
View raw message