karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Nodet <gno...@apache.org>
Subject Re: Conflicting versions of org.ow2.asm/asm-all
Date Tue, 06 Dec 2016 07:41:19 GMT
It's perfectly legal (and supported) to deploy a bundle in two different
versions.
In this case, I think the bundle has been uninstalled while waiting for the
lock to start it, which could explain the exception you see.
If the problem is reproductible, could you explain the steps ?

2016-12-06 3:49 GMT+01:00 Dario Amiri <dariushamiri@hotmail.com>:

> I'm seeing errors like this when starting 4.1.0-SNAPSHOT
>
> 2016-12-05T18:23:57,843 | ERROR | FelixStartLevel  |
> Felix                            |  -  -  | Bundle org.objectweb.asm.all
> [54] Error locking mvn:org.ow2.asm/asm-all/6.0_ALPHA
> (java.lang.IllegalStateException: Bundle in unexpected state.)
> java.lang.IllegalStateException: Bundle in unexpected state.
>      at
> org.apache.felix.framework.Felix.acquireBundleLock(Felix.java:5272) [?:?]
>      at
> org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1524)
> [?:?]
>      at
> org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:338)
> [?:?]
>      at java.lang.Thread.run(Thread.java:745) [?:?]
> 2016-12-05T18:23:57,844 | INFO  | CM Configuration Updater
> (ManagedService Update: pid=[org.apache.cxf.osgi]) |
> TldScanner                       | 189 - org.ops4j.pax.web.pax-web-jsp -
> 4.4.0 | found TLD bundle://189.0:0/META-INF/c.tld
> 2016-12-05T18:23:57,841 | ERROR | FelixDispatchQueue |
> all                              | 184 - org.objectweb.asm.all - 5.0.2 |
> FrameworkEvent ERROR - org.objectweb.asm.all
> java.lang.IllegalStateException: Bundle in unexpected state.
>      at
> org.apache.felix.framework.Felix.acquireBundleLock(Felix.java:5272) [?:?]
>      at
> org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1524)
> [?:?]
>      at
> org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:338)
> [?:?]
>      at java.lang.Thread.run(Thread.java:745) [?:?]
>
> Digging around a bit I can see that there are conflicting versions of
> org.ow2.asm/asm-all between the aries-blueprint feature version
> 4.1.0-SNAPSHOT, which brings in aries-proxy which requires
> org.ow2.asm/asm-all/6.0_ALPHA, and pax-http feature version 4.4.0, which
> brings in pax-http-jetty which requires org.ow2.asm/asm-all/5.0.2. I'm
> not sure if this is what is causing the error in the logs.
>
> One other thing worth noting is that my bundle list only shows
> org.ow2.asm/asm-all/5.0.2 loaded but org.ow2.asm/asm-all/6.0_ALPHA is in
> the system directory of the container and I am perfectly able to load it
> manually after the container loads. I would welcome any input on how to
> resolve this issue.
>
>


-- 
------------------------
Guillaume Nodet
------------------------
Red Hat, Open Source Integration

Email: gnodet@redhat.com
Web: http://fusesource.com
Blog: http://gnodet.blogspot.com/

Mime
View raw message