karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Nodet <gno...@apache.org>
Subject Re: Don't understand: missing requirement
Date Wed, 14 Dec 2016 17:26:35 GMT
The bundle has a requirement on an OSGi service using the interface/class
com.y.SomeAPI

2016-12-14 18:10 GMT+01:00 CLEMENT Jean-Philippe <
jean-philippe.clement@fr.thalesgroup.com>:

> Hello,
>
> We did a small change somewhere leading a Karaf freeze. Karaf (4.0.7) is
> assembled with our features.
>
> The log contains:
> [caused by: Unable to resolve com.X/1.0.5.SNAPSHOT: missing requirement
> [com.X/1.0.5.SNAPSHOT] osgi.service; effective:=active;
> filter:="(objectClass=com.y.SomeAPI)"]
>
> I don't really catch - what does this message mean?
>
> Thank you :)
>
> Regards,
> JP
>



-- 
------------------------
Guillaume Nodet
------------------------
Red Hat, Open Source Integration

Email: gnodet@redhat.com
Web: http://fusesource.com
Blog: http://gnodet.blogspot.com/

Mime
View raw message