karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CodeCola <prasen...@rogers.com>
Subject Unsatisfied Requirements: on Node 2
Date Tue, 20 Dec 2016 23:35:44 GMT
When I start a second Karaf Node, I get this
(note it won't appear on the first Node 1 - even though it is a folder copy
of the first)

Unsatisfied Requirements:
Unsatisfied Requirements:
[org.apache.karaf.decanter.appender.elasticsearch.rest [117](R 117.0)]
osgi.wiring.package; (osgi.wiring.package=org.apache.log)
Unsatisfied Requirements:
[org.apache.karaf.decanter.kibana-4.x [118](R 118.0)] osgi.wiring.package;
(osgi.wiring.package=org.apache.log)
Unsatisfied Requirements:
Unsatisfied Requirements:
[org.apache.karaf.decanter.appender.elasticsearch.rest [117](R 117.0)]
osgi.wiring.package; (osgi.wiring.package=org.apache.log)
Unsatisfied Requirements:
[org.apache.karaf.decanter.kibana-4.x [118](R 118.0)] osgi.wiring.package;
(osgi.wiring.package=org.apache.log)


If I do this on Node 1:


*feature:list | grep -i elasticsearch*

karaf@root()> feature:list | grep -i elasticsearch
decanter-appender-elasticsearch            | 1.2.0            | x        |
Started     | karaf-decanter-1.2.0     | Karaf Decanter Elasticsearch Native
2.x Appender
decanter-appender-elasticsearch-native-1.x | 1.2.0            |          |
Uninstalled | karaf-decanter-1.2.0     | Karaf Decanter Elasticsearch Native
1.x Appender
decanter-appender-elasticsearch-native-2.x | 1.2.0            |          |
Started     | karaf-decanter-1.2.0     | Karaf Decanter Elasticsearch Native
2.x Appender
decanter-appender-elasticsearch-rest       | 1.2.0            | x        |
Started     | karaf-decanter-1.2.0     | Karaf Decanter Elasticsearch HTTP
REST Appender
elasticsearch                              | 1.7.4            |          |
Uninstalled | karaf-decanter-1.2.0     | Embedded Elasticsearch 1.x node
elasticsearch                              | 2.2.0            | x        |
Started     | karaf-decanter-1.2.0     | Embedded Elasticsearch 2.x node
elasticsearch-head                         | 1.7.4            |          |
Uninstalled | karaf-decanter-1.2.0     | Elasticsearch Head web frontend
elasticsearch-head                         | 2.2.0            |          |
Uninstalled | karaf-decanter-1.2.0     | Elasticsearch Head web frontend




It just keeps going --


karaf@root()> Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:
Unsatisfied Requirements:



--
View this message in context: http://karaf.922171.n3.nabble.com/Unsatisfied-Requirements-on-Node-2-tp4049058.html
Sent from the Karaf - User mailing list archive at Nabble.com.

Mime
View raw message