karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leschke, Scott" <SLesc...@medline.com>
Subject RE: shell:exec
Date Thu, 03 Nov 2016 21:54:37 GMT
Thanks, but I tried that among a variety of other/similar things.  All have the same effect
when I try to invoke a windows command directly.  OTOH, I am able to get a .bat file to run
(exec path\to\some.bat).  That solved my problem even though I find it a bit distasteful.
It’s not that important though so I’ll look at it again when I get a chance.

Thx again.

From: John Poth [mailto:poth.john@gmail.com]
Sent: Thursday, November 03, 2016 4:04 AM
To: user@karaf.apache.org
Subject: Re: shell:exec

Hi,

You have to escape the backslashes with another backslash in the paths if you haven't already,
so something like

shell:exec copy C:\\path\\to\\file.bar foo.bar

Should do the trick. If not absolute, the paths will be relative to your Karaf installation
directory.

cheers,

John.

On Wed, Nov 2, 2016 at 10:22 PM, Leschke, Scott <SLeschke@medline.com<mailto:SLeschke@medline.com>>
wrote:
What’s the trick to getting this to work?  I just want to copy a file from one place to
another on windows and no matter what I try, I get
“System Error 2: The system cannot find the file specified (or something to that effect)”
even though the paths are absolute.

Anybody have an example of usage?

Mime
View raw message