karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Karaf 4.0.5 prerequisite feature not installed with correct version
Date Tue, 30 Aug 2016 19:59:11 GMT
By the way: it's the OSGi convention. The same apply to import package. 
Something like:

Import-Package: com.foo;version="1.0.0"

means [1.0.0,)

If you want to narrow to 1.0.0 only then you have to use [1.0.0,1.0.0]

Regards
JB

On 08/30/2016 09:24 PM, oski_bear wrote:
> Thanks Guillaume,
>
> The version range helped. Though, I think it's confusing that explicitly
> setting a version translates to >=. After all I am using the "=" symbol not
> the ">=" symbol.
>
> I'm going to investigate the other issues a bit more and get back to you.
>
> Thanks again
>
>
>
>
> --
> View this message in context: http://karaf.922171.n3.nabble.com/Karaf-4-0-5-prerequisite-feature-not-installed-with-correct-version-tp4047753p4047761.html
> Sent from the Karaf - User mailing list archive at Nabble.com.
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message