karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: service wrapper bug?
Date Fri, 05 Aug 2016 19:51:55 GMT
Hi Scott

Can you create a Jira about that ? I will take a look.

Thanks
Regards
JB



On Aug 5, 2016, 21:48, at 21:48, "Leschke, Scott" <SLeschke@medline.com> wrote:
>Ran into a minor issue using the service-wrapper feature on Karaf
>4.0.5/Windows.
>
>After installing the feature, we ran the wrapper:install command per
>the docs.  That worked fine. When we tried to start the service though
>it failed.  Upon review, I saw that the {service-name}-wrapper.conf
>file had the following lines in it.  This file is created under
>KARAF_BASE/etc.
>
>wrapper.java.classpath.2=%KARAF_HOME%/lib/wrapper/*.jar
>wrapper.java.library.path.1=%KARAF_HOME%/lib/wrapper/
>
>I've redefined KARAF_BASE to be outside the KARAF_HOME hierarchy. 
>Changing these two lines to the following allowed the service to start.
>
>wrapper.java.classpath.2=%KARAF_BASE%/lib/wrapper/*.jar
>wrapper.java.library.path.1=%KARAF_BASE%/lib/wrapper/
>
>
>I'm assuming this is the correct solution as wrapper:install created
>the bin and lib folders under KARAF_BASE (bin and lib) and not
>KARAF_HOME.
>Would it also be fair to assume this is a known issue?
>
>Regards,
>
>Scott

Mime
View raw message