karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diamantis Karagkiaouris <diam.karag....@gmail.com>
Subject Wrap command Karaf 4.0.5
Date Fri, 06 May 2016 12:24:53 GMT
Hello again,

I have already started my journey with Karaf and i enjoy the process,
although i have recently faced an issue with jasper-reports and wrap
command. I found some info that has to do with manifest version.

 | ERROR | nsole user karaf | ShellUtil                        | 44 -
> org.apache.karaf.shell.core - 4.0.5 | Exception caught while executing
> command
> org.osgi.framework.BundleException: Unable to build resource for
> mvn:net.sf.jasperreports/jasperreports/5.5.1: Unsupported
> 'Bundle-ManifestVersion' value: 1
>  at
> org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:80)[9:org.apache.karaf.features.core:4.0.5]
>  at
> org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:65)[9:org.apache.karaf.features.core:4.0.5]
>  at
> org.apache.karaf.features.internal.region.SubsystemResolver.prepare(SubsystemResolver.java:143)[9:org.apache.karaf.features.core:4.0.5]
>  at
> org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:218)[9:org.apache.karaf.features.core:4.0.5]
>  at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1152)[9:org.apache.karaf.features.core:4.0.5]
>  at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:1048)[9:org.apache.karaf.features.core:4.0.5]
>  at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_55]
>  at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[:1.7.0_55]
>  at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[:1.7.0_55]
>  at java.lang.Thread.run(Thread.java:745)[:1.7.0_55]
> Caused by: org.osgi.framework.BundleException: Unsupported
> 'Bundle-ManifestVersion' value: 1
>  at
> org.apache.karaf.features.internal.resolver.ResourceBuilder.doBuild(ResourceBuilder.java:88)[9:org.apache.karaf.features.core:4.0.5]
>  at
> org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:78)[9:org.apache.karaf.features.core:4.0.5]
>  ... 9 more
>

Based on what i have searched, wrapping this module - bundle will be
feasible by any of these:

Karaf shell:

> bundle:install -s wrap:mvn:net.sf.jasperreports/jasperreports/5.5.1
>

feature.xml

> <bundle>wrap:mvn:net.sf.jasperreports/jasperreports/5.5.1</bundle>
>

But unfortunately neither of them is working. Every time it throws the same
error. Is it a known bug? Is there any workaround for this? Any help will
be appreciated!

Thank you very much,
Diamantis

Mime
View raw message