karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Carr <kscar...@gmail.com>
Subject Re: Wrap command Karaf 4.0.5
Date Fri, 06 May 2016 12:38:39 GMT
There are a few support jars that have to be included.  I will get the
install list.  I believe the version I have is 4.0.5.

I am currently not at a computer though.

On Fri, May 6, 2016, 7:37 AM Diamantis Karagkiaouris <
diam.karag.dev@gmail.com> wrote:

> Hello,
>
> Jasper Reports version 5.5.1. Also i have tried the following with 4.0.3:
>
>
>> <bundle>wrap:mvn:net.sf.jasperreports/jasperreports/${version.jasperrreports}</bundle>
>>
>
> and the error thrown in karaf.log is:
>
> 2016-05-06 15:30:18,923 | ERROR | nsole user karaf |
>> ShellUtil                        | 44 - org.apache.karaf.shell.core - 4.0.3
>> | Exception caught while executing command
>> org.apache.karaf.features.internal.util.MultiException: Error
>>     at
>> org.apache.karaf.features.internal.download.impl.MavenDownloadManager$MavenDownloader.<init>(MavenDownloadManager.java:84)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.MavenDownloadManager.createDownloader(MavenDownloadManager.java:72)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.region.Subsystem.downloadBundles(Subsystem.java:358)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.region.Subsystem.downloadBundles(Subsystem.java:355)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:191)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:263)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1079)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:975)[9:org.apache.karaf.features.core:4.0.3]
>
>
>>     at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_55]
>>     at
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[:1.7.0_55]
>>     at
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[:1.7.0_55]
>>     at java.lang.Thread.run(Thread.java:745)[:1.7.0_55]
>>
> Caused by: java.lang.Exception: Unable to create resource for bundle
>> wrap:mvn:net.sf.jasperreports/jasperreports/5.5.1
>>     at
>> org.apache.karaf.features.internal.region.Subsystem.createResource(Subsystem.java:567)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.region.Subsystem$1.downloaded(Subsystem.java:376)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.MavenDownloadManager$MavenDownloader$1.operationComplete(MavenDownloadManager.java:133)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.MavenDownloadManager$MavenDownloader$1.operationComplete(MavenDownloadManager.java:127)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.DefaultFuture.notifyListener(DefaultFuture.java:344)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.DefaultFuture.notifyListeners(DefaultFuture.java:329)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.DefaultFuture.setValue(DefaultFuture.java:255)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.AbstractDownloadTask.setFile(AbstractDownloadTask.java:61)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.MavenDownloadManager$MavenDownloader$ChainedDownloadTask$1$1.downloaded(MavenDownloadManager.java:203)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.MavenDownloadManager$MavenDownloader$1.operationComplete(MavenDownloadManager.java:133)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.MavenDownloadManager$MavenDownloader$1.operationComplete(MavenDownloadManager.java:127)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.DefaultFuture.notifyListener(DefaultFuture.java:344)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.DefaultFuture.notifyListeners(DefaultFuture.java:329)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.DefaultFuture.setValue(DefaultFuture.java:255)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.AbstractDownloadTask.setFile(AbstractDownloadTask.java:61)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.download.impl.AbstractRetryableDownloadTask.run(AbstractRetryableDownloadTask.java:59)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[:1.7.0_55]
>>     at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_55]
>>     at
>> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:178)[:1.7.0_55]
>>     at
>> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:292)[:1.7.0_55]
>>     ... 3 more
>> Caused by: org.osgi.framework.BundleException: Unable to build resource
>> for wrap:mvn:net.sf.jasperreports/jasperreports/5.5.1: Unsupported
>> 'Bundle-ManifestVersion' value: 1
>>     at
>> org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:80)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:69)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.region.Subsystem.createResource(Subsystem.java:565)[9:org.apache.karaf.features.core:4.0.3]
>>     ... 22 more
>
>
>> Caused by: org.osgi.framework.BundleException: Unsupported
>> 'Bundle-ManifestVersion' value: 1
>>
>     at
>> org.apache.karaf.features.internal.resolver.ResourceBuilder.doBuild(ResourceBuilder.java:88)[9:org.apache.karaf.features.core:4.0.3]
>>     at
>> org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:78)[9:org.apache.karaf.features.core:4.0.3]
>>     ... 24 more
>>
>
>
> 2016-05-06 15:26 GMT+03:00 Kevin Carr <kscarr73@gmail.com>:
>
>> Which version of Jasper reports?  I have a script that installs Jasper in
>> karaf.  Been using it for several years.
>>
>> On Fri, May 6, 2016, 7:25 AM Diamantis Karagkiaouris <
>> diam.karag.dev@gmail.com> wrote:
>>
>>> Hello again,
>>>
>>> I have already started my journey with Karaf and i enjoy the process,
>>> although i have recently faced an issue with jasper-reports and wrap
>>> command. I found some info that has to do with manifest version.
>>>
>>>  | ERROR | nsole user karaf | ShellUtil                        | 44 -
>>>> org.apache.karaf.shell.core - 4.0.5 | Exception caught while executing
>>>> command
>>>> org.osgi.framework.BundleException: Unable to build resource for
>>>> mvn:net.sf.jasperreports/jasperreports/5.5.1: Unsupported
>>>> 'Bundle-ManifestVersion' value: 1
>>>>  at
>>>> org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:80)[9:org.apache.karaf.features.core:4.0.5]
>>>>  at
>>>> org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:65)[9:org.apache.karaf.features.core:4.0.5]
>>>>  at
>>>> org.apache.karaf.features.internal.region.SubsystemResolver.prepare(SubsystemResolver.java:143)[9:org.apache.karaf.features.core:4.0.5]
>>>>  at
>>>> org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:218)[9:org.apache.karaf.features.core:4.0.5]
>>>>  at
>>>> org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1152)[9:org.apache.karaf.features.core:4.0.5]
>>>>  at
>>>> org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:1048)[9:org.apache.karaf.features.core:4.0.5]
>>>>  at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_55]
>>>>  at
>>>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[:1.7.0_55]
>>>>  at
>>>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[:1.7.0_55]
>>>>  at java.lang.Thread.run(Thread.java:745)[:1.7.0_55]
>>>> Caused by: org.osgi.framework.BundleException: Unsupported
>>>> 'Bundle-ManifestVersion' value: 1
>>>>  at
>>>> org.apache.karaf.features.internal.resolver.ResourceBuilder.doBuild(ResourceBuilder.java:88)[9:org.apache.karaf.features.core:4.0.5]
>>>>  at
>>>> org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:78)[9:org.apache.karaf.features.core:4.0.5]
>>>>  ... 9 more
>>>>
>>>
>>> Based on what i have searched, wrapping this module - bundle will be
>>> feasible by any of these:
>>>
>>> Karaf shell:
>>>
>>>> bundle:install -s wrap:mvn:net.sf.jasperreports/jasperreports/5.5.1
>>>>
>>>
>>> feature.xml
>>>
>>>> <bundle>wrap:mvn:net.sf.jasperreports/jasperreports/5.5.1</bundle>
>>>>
>>>
>>> But unfortunately neither of them is working. Every time it throws the
>>> same error. Is it a known bug? Is there any workaround for this? Any help
>>> will be appreciated!
>>>
>>> Thank you very much,
>>> Diamantis
>>>
>>
>

Mime
View raw message