karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Moritz Petersen <mpete...@adobe.com>
Subject Re: Karaf 2.4.x with PAX Logging 1.8.5
Date Fri, 06 May 2016 13:50:15 GMT
Hi JB,

thanks, so am I right, that I need pax-logging 1.8.5 for Log4j 2 support?

Kind regards, Moritz 




On 06.05.16, 14:20, "Jean-Baptiste Onofré" <jb@nanthrax.net> wrote:

>Hi Moritz,
>
>you have to:
>
>1. Update the artifacts in the Karaf system folder
>2. Update etc/startup.properties with the right version, same in bin/* 
>scripts
>3. Update the following features XML:
>
>system/org/apache/karaf/assemblies/features/standard/2.4.5-SNAPSHOT/standard-2.4.5-SNAPSHOT-features.xml
>
>system/org/apache/karaf/assemblies/features/enterprise/2.4.5-SNAPSHOT/enterprise-2.4.5-SNAPSHOT-features.xml
>
>Regards
>JB
>
>On 05/06/2016 02:16 PM, Moritz Petersen wrote:
>> Hi,
>>
>> I’m trying to update PAX Logging to 1.8.5 in a Karaf 2.4.x installation.
>> By default Karaf 2.4.2 comes with pax-logging 1.8.2 and Karaf 2.4.4
>> comes with pax-logging 1.8.4.
>>
>> However, if I’m not mistaken, Log4j 2 is only integrated in pax-logging
>> 1.8.5.
>>
>> My question is either:
>>
>>   * How can I update PAX logging in a Karaf 2.4.x installation?
>>
>> or
>>
>>   * How can I use Log4j 2 with a Karaf 2.4.x installation?
>>
>> Thank you,
>> Moritz
>
>-- 
>Jean-Baptiste Onofré
>jbonofre@apache.org
>http://blog.nanthrax.net
>Talend - http://www.talend.com
Mime
View raw message