karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david.a.jen...@gmail.com>
Subject Re: Bundle startup
Date Wed, 04 May 2016 03:09:49 GMT
There must be a lot more going on for this to fail.  This kind of situation normally works
fine with scr.  If you turn up ds logging, what do you see as the reason your component won’t
start?  What does the console say about the state of the component (assuming the console uses
the scr commands or equivalent info).

thanks
david jencks

> On May 3, 2016, at 7:58 PM, David Leangen <apache@leangen.net> wrote:
> 
> 
> Hi!
> 
> When I start up Karaf, all my bundles are activated, but a component service is one bundle
is not enabled.
> 
> The service does not start because it is not provided with a UserAdmin. Judging by the
ordering, this is surely true when the system starts.
> 
> When I log into the console (after all bundles have activated), I can see that there
is indeed a UserAdmin. If I restart my bundle, the UserAdmin dependency is wired and my component
gets enabled. If I restart the container after that, there are no problems. This problem only
occurs upon initial startup.
> 
> 
> I suspect this is a bug with SCR. Likely, after the initial try, it does not try to activate
the component again even if it finds a UserAdmin. But before I file a bug, does anybody have
any suggestions as to how I can confirm?
> 
> 
> Thanks!
> =David
> 
> 


Mime
View raw message