karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Karaf 4.0.4-SNAPSHOT freeze
Date Tue, 05 Jan 2016 15:57:53 GMT
Are you sure those bundles don't require equinox framework (packages) ?

It seems that you use felix framework, right ?

Regards
JB

On 01/05/2016 04:54 PM, CLEMENT Jean-Philippe wrote:
> <feature name="XXX">
>          <!-- eclipse dependencies  -->
>          <bundle>mvn:org.eclipse.core/contenttype/3.4.200.v20140207-1251</bundle>
>          <bundle>mvn:org.eclipse.core/jobs/3.6.0.v20140424-0053</bundle>
>          <bundle>mvn:org.eclipse.core/runtime/3.10.0.v20140318-2214</bundle>
>          <bundle>mvn:org.eclipse.equinox/app/1.3.200.v20130910-1609</bundle>
>          <bundle>mvn:org.eclipse.equinox/common/3.6.200.v20130402-1505</bundle>
>          <bundle>mvn:org.eclipse.equinox/preferences/3.5.200.v20140224-1527</bundle>
>          <bundle>mvn:org.eclipse.equinox/registry/3.5.400.v20140428-1507</bundle>
>
>          <bundle>mvn:com.google.guava/guava/15.0</bundle>
>          ...
> </feature>
>
> JP
>
> [@@ OPEN @@]
>
>
> -----Message d'origine-----
> De : Jean-Baptiste Onofré [mailto:jb@nanthrax.net]
> Envoyé : mardi 5 janvier 2016 16:47
> À : user@karaf.apache.org
> Objet : Re: Karaf 4.0.4-SNAPSHOT freeze
>
> Hi JP,
>
> it sounds like your feature requires XXX feature which is not found.
>
> Can you share your features XML ?
>
> Regards
> JB
>
>
> On 01/05/2016 04:34 PM, CLEMENT Jean-Philippe wrote:
>> Dear Karaf Team,
>>
>> Happy New Year :)
>>
>> I just assembled Karaf 4.0.4-SNAPSHOT. It seems the snapshot content changed as now
it freezes at startup before displaying the branding.
>>
>> The log mentions a missing requirement on org.eclipse.core.runtime/3.10.0v20140318-2214
but the bundle is part of the feature:
>>
>> 2016-01-05 15:03:36,348 | ERROR | pool-6-thread-1  | BootFeaturesInstaller      
     | 7 - org.apache.karaf.features.core - 4.0.4.SNAPSHOT | Error installing boot features
>> org.osgi.service.resolver.ResolutionException: Unable to resolve root: missing requirement
[root] osgi.identity; osgi.identity=XXX; type=karaf.feature; version=0 [caused by: Unable
to resolve XXX/0.0.0: missing requirement [XXX/0.0.0] osgi.identity; osgi.identity=org.eclipse.core.runtime;
type=osgi.bundle; version="[3.10.0.v20140318-2214,3.10.0.v20140318-2214]"; resolution:=mandatory
[caused by: Unable to resolve org.eclipse.core.runtime/3.10.0.v20140318-2214: missing requirement
[org.eclipse.core.runtime/3.10.0.v20140318-2214] osgi.wiring.bundle; osgi.wiring.bundle=org.eclipse.osgi;
bundle-version="[3.7.0,4.0.0)"; visibility:=reexport; filter:="(&(osgi.wiring.bundle=org.eclipse.osgi)(bundle-version>=3.7.0)(!(bundle-version>=4.0.0)))"]]
>>           at org.apache.felix.resolver.ResolutionError.toException(ResolutionError.java:42)[org.apache.felix.framework-5.4.0.jar:]
>>           at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:235)[org.apache.felix.framework-5.4.0.jar:]
>>           at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:158)[org.apache.felix.framework-5.4.0.jar:]
>>           at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:220)[7:org.apache.karaf.features.core:4.0.4.SNAPSHOT]
>>           at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:263)[7:org.apache.karaf.features.core:4.0.4.SNAPSHOT]
>>           at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1085)[7:org.apache.karaf.features.core:4.0.4.SNAPSHOT]
>>           at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:981)[7:org.apache.karaf.features.core:4.0.4.SNAPSHOT]
>>           at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_72-ea]
>>           at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_72-ea]
>>           at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_72-ea]
>>           at java.lang.Thread.run(Thread.java:745)[:1.8.0_72-ea]
>>
>> How to fix this?
>>
>> Regards,
>> JP
>>
>> [@@ OPEN @@]
>>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message