karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: OpenJPA feature and Java 8
Date Mon, 10 Aug 2015 12:11:09 GMT
Hi Charlie,

thanks for the update. I talked about 2.2.0.

I will update to 2.2.2 in Karaf 4 already, and I will provide 2.4.0 
feature (I already have it on a local branch).

Let me create the Jira to include it in Karaf 4.0.1.

Regards
JB

On 08/10/2015 02:08 PM, Charlie Mordant wrote:
> Hi guys,
>
> OpenJPA 2.2.2 does support Java8, but not the 2.3 (the 2.2.x was a fork
> used by OpenEJB). OpenJPA 2.4.x is the merge between 2.2.2 and 2.3 as
> well as some start of work on JPA API 2.1
>
> http://openjpa.208410.n2.nabble.com/Java-8-Java-7-end-of-life-td7587781.html
>
> http://openjpa.208410.n2.nabble.com/VOTE-Release-Apache-OpenJPA-2-4-0-td7587966.html
>
> and
>
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12310351&version=12325298
>
> JB, if you want a 2.4 feature, you can copy/paste the one that's in
> Osgiliath (basically, it contains the same jars as the 2.3 one with some
> bundle version upgrade).
>
> Regards,
>
> Regards,
>
> 2015-08-10 13:11 GMT+02:00 Jean-Baptiste Onofré <jb@nanthrax.net
> <mailto:jb@nanthrax.net>>:
>
>     OpenJPA 2.2.2 and 2.3.0 are both Java 7 and JPA 2.0.
>
>     OpenJPA 2.4.0 has been released, but I didn't check yet. I gonna add
>     the corresponding feature.
>
>     If you want, I can define openjpa features more "flexible" to
>     support Java 1.8 but it's at your own risk ;)
>
>     Regards
>     JB
>
>
>     On 08/10/2015 11:56 AM, ellirael wrote:
>
>         What about OpenJPA 2.3.x?
>         According to enterprise-4.0.0-features.xml both OpenJPA versions
>         require
>         Java 1.7:
>
>         <feature name="openjpa" description="Apache OpenJPA 2.2.x
>         persistence engine
>         support" version="2.2.2">
>         ...
>         <requirement>osgi.ee
>         <http://osgi.ee>;filter:=&quot;(&amp;(osgi.ee
>         <http://osgi.ee>=JavaSE)(!(version&gt;=1.8)))&quot;</requirement>
>         </feature>
>
>         <feature name="openjpa" description="Apache OpenJPA 2.3.x
>         persistence engine
>         support" version="2.3.0">
>         ...
>         <requirement>osgi.ee
>         <http://osgi.ee>;filter:=&quot;(&amp;(osgi.ee
>         <http://osgi.ee>=JavaSE)(!(version&gt;=1.8)))&quot;</requirement>
>         </feature>
>
>         May it be some sort of an error?
>
>
>
>         --
>         View this message in context:
>         http://karaf.922171.n3.nabble.com/OpenJPA-feature-and-Java-8-tp4041811p4041813.html
>         Sent from the Karaf - User mailing list archive at Nabble.com.
>
>
>     --
>     Jean-Baptiste Onofré
>     jbonofre@apache.org <mailto:jbonofre@apache.org>
>     http://blog.nanthrax.net
>     Talend - http://www.talend.com
>
>
>
>
> --
> Charlie Mordant
>
> Full OSGI/EE stack made with Karaf:
> https://github.com/OsgiliathEnterprise/net.osgiliath.parent

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message