karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Achim Nierbeck <bcanh...@googlemail.com>
Subject Re: Bundle not sync'ing
Date Tue, 10 Mar 2015 07:59:26 GMT
Hi,

if you install a bundle via a maven coordinate, this coordinate is
propagated to the other nodes, no binaries are transfered.
Btw. that's why a sync of the deploy folder doesn't work :-)
The repo which contains this maven artifact needs to be known to all nodes.
For this you can use the cluster:config* commands to share this
information.


If you want to make sure that a bundle is installed throughout the cluster
you usually should use the cluster:bundle-install command.
With the next version of cellar we disabled the default propagation of all
installed bundles due to some unwanted side effects that showed on a
multi-node cluster where one node is recovering.

regards, Achim


2015-03-09 22:08 GMT+01:00 sditlinger <steve@ditlinger.com>:

> OK, it turns out that the original services installed did have a copy of
> the
> maven repository on the remote node.  That must be the difference.
>
> Is it correct to say that remote nodes do require access to the
> installation
> maven repository when bundle-install'ing from a maven URL
> (mvn:groupID/artifactID/version) - that the bundle is not copied "over the
> wire" by Cellar from the node where it is originally installed?
>
>
>
> Steve
>
>
>
> --
> View this message in context:
> http://karaf.922171.n3.nabble.com/Bundle-not-sync-ing-tp4038887p4038895.html
> Sent from the Karaf - User mailing list archive at Nabble.com.
>



-- 

Apache Member
Apache Karaf <http://karaf.apache.org/> Committer & PMC
OPS4J Pax Web <http://wiki.ops4j.org/display/paxweb/Pax+Web/> Committer &
Project Lead
blog <http://notizblog.nierbeck.de/>
Co-Author of Apache Karaf Cookbook <http://bit.ly/1ps9rkS>

Software Architect / Project Manager / Scrum Master

Mime
View raw message