karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Carr <kscar...@gmail.com>
Subject Re: bundle corruption with felix and karaf 3.0.2
Date Thu, 08 Jan 2015 00:54:12 GMT
I have seen this as well. If you try to do anything with the bundle it says
No Bundle message.

For us, it only happens if the process is killed as well.
On Jan 7, 2015 6:13 PM, "asookazian2" <asookazian@gmail.com> wrote:

> Karaf 3.0.2
>
> we are seeing intermittent hanging on halt (shutdown) of karaf.  we then
> use
> 'kill -9' on karaf java process.  then, sometimes after a restart, we are
> seeing some bundles (typically the last n bundles) in 'installed' state.  I
> believe I saw on this forum JB commented the root cause of this is a felix
> bug.  Any details on this JIRA, etc. and when it may be fixed?  Has anybody
> else seen this behavior?
>
> In the log we are seeing:
>
> 20150107 15:38:22.613 [WARN ] ActiveMQ Task-3 |
> 147:org.apache.activemq.activemq-osgi |
> org.apache.activemq.transport.failover.FailoverTransport | Failed to
> connect
> to [tcp://localhost:61616] after: 10 attempt(s) continuing to retry.
>
> Also, i noticed today that I could not 'uninstall <bundleId>' for these
> corrupted bundles.  Should we just delete them manually from
> kara/data/cache/<bundleId> directory and restart karaf?  thx for any help.
>
> btw, we tried switching to equinox but we had other issues with that so
> back
> with felix for now.
>
>
>
> --
> View this message in context:
> http://karaf.922171.n3.nabble.com/bundle-corruption-with-felix-and-karaf-3-0-2-tp4037669.html
> Sent from the Karaf - User mailing list archive at Nabble.com.
>

Mime
View raw message