karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Carr <kscar...@gmail.com>
Subject Handling HandshakeCompletedListener for IBM Mq Properly
Date Mon, 10 Mar 2014 19:28:06 GMT
FuseSource issue:  http://fusesource.com/issues/browse/ESB-1645

Error:  java.lang.ClassNotFoundException:
javax.net.ssl.HandshakeCompletedListener not found by
com.ibm.msg.client.osgi.wmq

I found a couple pages that reference this error, with the solution of
Change to Equinox. I have found what I believe the more correct way, and
wanted to post it here.

I tried to update the issue, but it does not allow posting a comment.

The issue is actually not with Felix or Equinox, it is with imports of IBM
MQ.

It does not list 2 imports that are needed by the bundle.  Technically, I
don't think Equinox should have worked either.

I fixed the issue by creating a IbmMqFragment with the following import:

-- MANIFEST.MF --

Fragment-Host: com.ibm.mq.osgi.java
Import-Package: javax.security.cert,javax.net.ssl

-- 
Scott Carr

Mime
View raw message