karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From asookazian2 <asookaz...@gmail.com>
Subject installing a specific feature version in karaf 3.0.0
Date Mon, 03 Mar 2014 19:57:40 GMT
I'm working on a JPA/Hibernate sample project and it's calling for the
following bundle installs:

install -s
mvn:org.hibernate.common/hibernate-commons-annotations/4.0.4.Final
install -s mvn:org.hibernate/hibernate-core/4.2.7.Final
install -s mvn:org.hibernate/hibernate-entitymanager/4.2.7.Final

When I run the following cmd 'feature:install jpa' I get JPA 1.0.1.  I'm not
sure that version is compatible with Hibernate 4.x.  How can I install JPA
2.x?

karaf cmd: 'feature:install jpa 2.0.0' does not seem to work.

I found this config xml file:

./system/org/apache/karaf/features/enterprise/3.0.0/enterprise-3.0.0-features.xml

It seems to specify JPA 1.0.1.  Must this file be directly edited so I can
install a different version of JPA?

https://github.com/lburgazzoli/lb-karaf-examples-jpa/tree/master/jpa-hibernate
<https://github.com/lburgazzoli/lb-karaf-examples-jpa/tree/master/jpa-hibernate>  

thx.



--
View this message in context: http://karaf.922171.n3.nabble.com/installing-a-specific-feature-version-in-karaf-3-0-0-tp4032022.html
Sent from the Karaf - User mailing list archive at Nabble.com.

Mime
View raw message