On Tue, Dec 31, 2013 at 11:03 PM, Jean-Baptiste Onofré <jb@nanthrax.net> wrote:
Hi Lothar,

org.apache.karaf.shell.table 3.0.0 is designed to work with Karaf 3.0.0.

However, we can extend the version range but table 3.0.0 with karaf 2.x is something that we don't maintain if you see bug in this situation.

I completely understand and accept that Karaf won't maintain an official Karaf 2.x compatibility for shell table.
However, as I am using RC1 with Karaf 2.x without problems and the bundle has only the one dependency to jansi I am confident that it would work just fine and the change would enable writing Karaf commands that work in both Karaf 2.x and Karaf 3.x. Therefore I would highly appreciate if the version range could be relaxed.

Regards
JB

Thanks!
--

Lothar Werzinger

Principal Architect

Tradescape, Inc. - Enabling Efficient Digital Marketplaces

+1-650-931-6719 (direct)

+1-800-697-6068 (main) Ext. 116

lothar@tradescape.biz

http://www.tradescape.biz




This message and any attachment (the "message") is intended solely for the addressees and is confidential. If you receive this message by mistake, please delete it and notify the sender immediately. Any use not in accordance with its purpose, any out-spread or disclosure, either as a whole or partially, is prohibited except with formal approval. Internet cannot guarantee the integrity of this message, therefore Tradescape will not be liable for the message if modified.

-