karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Pieber <anpie...@gmail.com>
Subject Re: pax-provision and profiles for Karaf 2.3.0
Date Wed, 31 Oct 2012 06:31:20 GMT
well, it's not surprising since org.ops4j.pax.url.pax-url-mvn/pax-url-mvn/1.3.5
is wrong... it should be org.ops4j.pax.url/pax-url-mvn/1.3.5

Do you think it could be a problem in pax-runner? Do you find the wrong
defined url anywhere? BTW, why do you need pax-runner(provision) for this?
Typically, here we've made ways better experiences building a karaf
assembly directly instead of using pax-provision.

Kind regards,
Andreas

On Mon, Oct 22, 2012 at 2:42 PM, Kjell Otto <otto.kjell@gmail.com> wrote:

> Just wanted to provide more information, now I've enabled the
> <param>--log=debug</param> flag.
> Output follows:
>
>  -> Succesfully downloaded to [runner/bundles/-1911136526.jar]
>  -> Downloading [mvn:org.ops4j.pax.url.pax-url-mvn/pax-url-mvn/1.3.5]
>  -> Creating new file at destination:
>
> /Users/kjellski/Projects/java/osgi/controlling/runner/bundles/-2136097610.jar
>  -> Resolving [mvn:org.ops4j.pax.url.pax-url-mvn/pax-url-mvn/1.3.5]g...
>  -> Using manager SimpleLocalRepositoryManager with priority 0 for
> /Users/kjellski/.m2/repository
>  -> Using connector WagonRepositoryConnector with priority 0 for
> file:/Users/kjellski/.m2/repository/
>  -> Using connector WagonRepositoryConnector with priority 0 for
> http://repo1.maven.org/maven2/ via localhost:1337
>  -> Using connector WagonRepositoryConnector with priority 0 for
> http://repository.ops4j.org/maven2/ via localhost:1337
>  -> Using connector WagonRepositoryConnector with priority 0 for
> http://scm.ops4j.org/repos/ops4j/projects/pax/runner-repository/ via
> localhost:1337
>  -> Using connector WagonRepositoryConnector with priority 0 for
> http://osgi.sonatype.org/content/groups/pax-runner/ via localhost:1337
>  -> Using connector WagonRepositoryConnector with priority 0 for
> http://repo1.maven.org/maven2/ via localhost:1337
>  -> Using connector WagonRepositoryConnector with priority 0 for
> http://repository.ops4j.org/maven2/ via localhost:1337
>  -> Using connector WagonRepositoryConnector with priority 0 for
> http://repository.springsource.com/maven/bundles/release/ via
> localhost:1337
>  -> Using connector WagonRepositoryConnector with priority 0 for
> http://repository.springsource.com/maven/bundles/external/ via
> localhost:1337
>
>          ___
>         /  /
>        /  / Oops, there has been a problem!
>       /  /
>      /__/   org.ops4j.pax.runner.platform.PlatformException:
> [mvn:org.ops4j.pax.url.pax-url-mvn/pax-url-mvn/1.3.5] could not be
> downloaded
>     ___
>    /__/
>
>  -> Exception caught during execution:
> java.lang.RuntimeException:
> org.ops4j.pax.runner.platform.PlatformException:
> [mvn:org.ops4j.pax.url.pax-url-mvn/pax-url-mvn/1.3.5] could not be
> downloaded
>         at org.ops4j.pax.runner.Run.startPlatform(Run.java:668)
>         at org.ops4j.pax.runner.Run.start(Run.java:207)
>         at org.ops4j.pax.runner.Run.main(Run.java:134)
>         at org.ops4j.pax.runner.Run.main(Run.java:102)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:597)
>         at
> org.ops4j.pax.construct.lifecycle.ProvisionMojo.invokePaxRunner(ProvisionMojo.java:837)
>         at
> org.ops4j.pax.construct.lifecycle.ProvisionMojo.deployRunnerNG(ProvisionMojo.java:815)
>         at
> org.ops4j.pax.construct.lifecycle.ProvisionMojo.deployBundles(ProvisionMojo.java:502)
>         at
> org.ops4j.pax.construct.lifecycle.ProvisionMojo.execute(ProvisionMojo.java:287)
>         at
> org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
>         at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
>         at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
>         at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
>         at
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
>         at
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
>         at
> org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
>         at
> org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
>         at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
>         at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:597)
>         at
> org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
>         at
> org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
>         at
> org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
>         at
> org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
> Caused by: org.ops4j.pax.runner.platform.PlatformException:
> [mvn:org.ops4j.pax.url.pax-url-mvn/pax-url-mvn/1.3.5] could not be
> downloaded
>         at
> org.ops4j.pax.runner.platform.internal.PlatformImpl.download(PlatformImpl.java:596)
>         at
> org.ops4j.pax.runner.platform.internal.PlatformImpl.downloadBundles(PlatformImpl.java:357)
>         at
> org.ops4j.pax.runner.platform.internal.PlatformImpl.start(PlatformImpl.java:162)
>         at org.ops4j.pax.runner.Run.startPlatform(Run.java:664)
>         ... 32 more
> Caused by: java.io.IOException: Aether Error.
>         at
> org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:234)
>         at
> org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:221)
>         at
> org.ops4j.pax.url.mvn.internal.Connection.getInputStream(Connection.java:120)
>         at java.net.URL.openStream(URL.java:1010)
>         at
> org.ops4j.pax.runner.platform.internal.StreamUtils.streamCopy(StreamUtils.java:105)
>         at
> org.ops4j.pax.runner.platform.internal.PlatformImpl.download(PlatformImpl.java:582)
>         ... 35 more
> Caused by: org.sonatype.aether.resolution.ArtifactResolutionException:
> Could not find artifact
> org.ops4j.pax.url.pax-url-mvn:pax-url-mvn:jar:1.3.5 in local
> (file:/Users/kjellski/.m2/repository/)
>         at
> org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:541)
>         at
> org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:220)
>         at
> org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:197)
>         at
> org.sonatype.aether.impl.internal.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:323)
>         at
> org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:232)
>         ... 40 more
> Caused by: org.sonatype.aether.transfer.ArtifactNotFoundException:
> Could not find artifact
> org.ops4j.pax.url.pax-url-mvn:pax-url-mvn:jar:1.3.5 in local
> (file:/Users/kjellski/.m2/repository/)
>         at
> org.sonatype.aether.connector.wagon.WagonRepositoryConnector$4.wrap(WagonRepositoryConnector.java:945)
>         at
> org.sonatype.aether.connector.wagon.WagonRepositoryConnector$4.wrap(WagonRepositoryConnector.java:940)
>         at
> org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.flush(WagonRepositoryConnector.java:695)
>         at
> org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.flush(WagonRepositoryConnector.java:689)
>         at
> org.sonatype.aether.connector.wagon.WagonRepositoryConnector.get(WagonRepositoryConnector.java:445)
>         at
> org.sonatype.aether.impl.internal.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:460)
>         ... 44 more
>
> Also, I've updated the gist to use exactly the dependencies from the
> downloadable karaf 2.3.0/etc/startup.properties:
> https://gist.github.com/3905879
>
> Hope it helps...
>
>
>
> 2012/10/22 Kjell Otto <otto.kjell@gmail.com>:
> > Hi there,
> >
> > I've just tried to come up with a profile to be able to run karaf in a
> provision
> > by pax-provision.
> >
> > Here is what I came up with, but it's not working since somehow it always
> > fails to install management:
> >
> > myProject]$ pax-provision
> > [INFO] Scanning for projects...
> > [WARNING]
> > [WARNING] Some problems were encountered while building the effective
> > model for
> examples.myProject.build:compiled-bundle-settings:pom:1.0-SNAPSHOT
> > [WARNING] The expression ${pom.version} is deprecated. Please use
> > ${project.version} instead.
> > [WARNING] The expression ${pom.version} is deprecated. Please use
> > ${project.version} instead.
> > [WARNING]
> > [WARNING] It is highly recommended to fix these problems because they
> > threaten the stability of your build.
> > [WARNING]
> > [WARNING] For this reason, future Maven versions might no longer
> > support building such malformed projects.
> > [WARNING]
> > [INFO]
> ------------------------------------------------------------------------
> > [INFO] Reactor Build Order:
> > [INFO]
> > [INFO] examples.myProject (OSGi project)
> > [INFO] myProject - plugin configuration
> > [INFO] myProject - wrapper instructions
> > [INFO] myProject - bundle instructions
> > [INFO] myProject - imported bundles
> > [INFO]
> > [INFO]
> ------------------------------------------------------------------------
> > [INFO] Building examples.myProject (OSGi project) 1.0-SNAPSHOT
> > [INFO]
> ------------------------------------------------------------------------
> > [INFO]
> > [INFO] --- maven-pax-plugin:1.5:provision (default-cli) @ myProject ---
> > [INFO] ~~~~~~~~~~~~~~~~~~~
> > [INFO]  No bundles found!
> > [INFO] ~~~~~~~~~~~~~~~~~~~
> > [INFO] Installing
> > /Users/kjellski/Projects/java/osgi/myProject/runner/deploy-pom.xml to
> >
> /Users/kjellski/.m2/repository/examples/myProject/build/deployment/1.0-SNAPSHOT/deployment-1.0-SNAPSHOT.pom
> > __________                 __________
> > \______   \_____  ___  ___ \______   \__ __  ____   ____   ___________
> > |     ___/\__  \ \  \/  /  |       _/  |  \/    \ /    \_/ __ \_  __ \
> > |    |     / __ \_>    <   |    |   \  |  /   |  \   |  \  ___/|  | \/
> > |____|    (____  /__/\_ \  |____|_  /____/|___|  /___|  /\___  >__|
> >                \/      \/         \/           \/     \/     \/
> >
> > Pax Runner (1.7.6) from OPS4J - http://www.ops4j.org
> > ----------------------------------------------------
> >
> >  -> Using only arguments from command line
> >  -> Scan bundles from
> > [/Users/kjellski/Projects/java/osgi/myProject/runner/deploy-pom.xml]
> >  -> Scan bundles from
> >
> [scan-pom:file:/Users/kjellski/Projects/java/osgi/myProject/runner/deploy-pom.xml]
> >  -> Scan bundles from
> >
> [scan-composite:mvn:org.ops4j.pax.runner.profiles/karaf.shell/2.3.0/composite]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.felix/org.apache.felix.configadmin/1.4.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.ops4j.pax.logging/pax-logging-api/1.7.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.ops4j.pax.logging/pax-logging-service/1.7.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.aries.blueprint/org.apache.aries.blueprint/1.0.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.aries.proxy/org.apache.aries.proxy/1.0.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.aries/org.apache.aries.util/1.0.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.asm/3.3_2]
> >  -> Scan bundles from [scan-bundle:mvn:org.apache.sshd/sshd-core/0.8.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.3.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.karaf.management/management/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.shell/org.apache.karaf.shell.commands/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.shell/org.apache.karaf.shell.config/2.3.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.karaf.shell/org.apache.karaf.shell.log/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.shell/org.apache.karaf.shell.osgi/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.features/org.apache.karaf.features.command/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.features/org.apache.karaf.features.management/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.features/org.apache.karaf.features.core/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.modules/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.config/2.3.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.boot/2.3.0]
> >  -> Scan bundles from
> >
> [scan-bundle:mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.features/2.3.0]
> >  -> Scan bundles from [scan-bundle:mvn:org.apache.mina/mina-core/2.0.7]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.karaf.shell/org.apache.karaf.shell.obr/2.3.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.karaf.shell/org.apache.karaf.shell.ssh/2.3.0]
> >  -> Scan bundles from
> > [scan-bundle:mvn:org.apache.felix/org.apache.felix.fileinstall/3.2.6]
> >  -> Provision bundle
> > [mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.felix/org.apache.felix.configadmin/1.4.0, at default
> > start level, bundle will be started, bundle will be loaded from the
> > cache]
> >  -> Provision bundle [mvn:org.ops4j.pax.logging/pax-logging-api/1.7.0,
> > at default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.ops4j.pax.logging/pax-logging-service/1.7.0, at default start
> > level, bundle will be started, bundle will be loaded from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.aries.blueprint/org.apache.aries.blueprint/1.0.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.aries.proxy/org.apache.aries.proxy/1.0.0, at default
> > start level, bundle will be started, bundle will be loaded from the
> > cache]
> >  -> Provision bundle
> > [mvn:org.apache.aries/org.apache.aries.util/1.0.0, at default start
> > level, bundle will be started, bundle will be loaded from the cache]
> >  -> Provision bundle
> >
> [mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.asm/3.3_2,
> > at default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle [mvn:org.apache.sshd/sshd-core/0.8.0, at default
> > start level, bundle will be started, bundle will be loaded from the
> > cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.management/management/2.3.0, at default start
> > level, bundle will be started, bundle will be loaded from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.shell/org.apache.karaf.shell.commands/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.shell/org.apache.karaf.shell.config/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.shell/org.apache.karaf.shell.log/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.shell/org.apache.karaf.shell.osgi/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.features/org.apache.karaf.features.command/2.3.0,
> > at default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> >
> [mvn:org.apache.karaf.features/org.apache.karaf.features.management/2.3.0,
> > at default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.features/org.apache.karaf.features.core/2.3.0,
> > at default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.modules/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.config/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.boot/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.features/2.3.0,
> > at default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle [mvn:org.apache.mina/mina-core/2.0.7, at default
> > start level, bundle will be started, bundle will be loaded from the
> > cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.shell/org.apache.karaf.shell.obr/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.karaf.shell/org.apache.karaf.shell.ssh/2.3.0, at
> > default start level, bundle will be started, bundle will be loaded
> > from the cache]
> >  -> Provision bundle
> > [mvn:org.apache.felix/org.apache.felix.fileinstall/3.2.6, at default
> > start level, bundle will be started, bundle will be loaded from the
> > cache]
> >  -> Preparing framework [Felix 4.0.2]
> >  -> Downloading bundles...
> >  -> Repository spec http://repo1.maven.org/maven2/ does not contain an
> > identifier. This is deprecated & discouraged & just evil.
> >  -> Repository spec http://repository.ops4j.org/maven2/ does not
> > contain an identifier. This is deprecated & discouraged & just evil.
> >  -> Resolved
> (org.apache.felix:org.apache.felix.bundlerepository:jar:1.6.6)
> > as
> /Users/kjellski/.m2/repository/org/apache/felix/org.apache.felix.bundlerepository/1.6.6/org.apache.felix.bundlerepository-1.6.6.jar
> >  -> mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6 :
> > 168279 bytes @ [ 56093kBps ]
> >  -> Resolved (org.apache.felix:org.apache.felix.configadmin:jar:1.4.0)
> > as
> /Users/kjellski/.m2/repository/org/apache/felix/org.apache.felix.configadmin/1.4.0/org.apache.felix.configadmin-1.4.0.jar
> >  -> mvn:org.apache.felix/org.apache.felix.configadmin/1.4.0 : 109181
> > bytes @ [ 109181kBps ]
> >  -> Resolved (org.ops4j.pax.logging:pax-logging-api:jar:1.7.0) as
> >
> /Users/kjellski/.m2/repository/org/ops4j/pax/logging/pax-logging-api/1.7.0/pax-logging-api-1.7.0.jar
> >  -> mvn:org.ops4j.pax.logging/pax-logging-api/1.7.0 : 94836 bytes @ [
> > 94836kBps ]
> >  -> Resolved (org.ops4j.pax.logging:pax-logging-service:jar:1.7.0) as
> >
> /Users/kjellski/.m2/repository/org/ops4j/pax/logging/pax-logging-service/1.7.0/pax-logging-service-1.7.0.jar
> >  -> mvn:org.ops4j.pax.logging/pax-logging-service/1.7.0 : 558076 bytes
> > @ [ 558076kBps ]
> >  -> Resolved
> (org.apache.aries.blueprint:org.apache.aries.blueprint:jar:1.0.0)
> > as
> /Users/kjellski/.m2/repository/org/apache/aries/blueprint/org.apache.aries.blueprint/1.0.0/org.apache.aries.blueprint-1.0.0.jar
> >  -> mvn:org.apache.aries.blueprint/org.apache.aries.blueprint/1.0.0 :
> > 437187 bytes @ [ 437187kBps ]
> >  -> Resolved (org.apache.aries.proxy:org.apache.aries.proxy:jar:1.0.0)
> > as
> /Users/kjellski/.m2/repository/org/apache/aries/proxy/org.apache.aries.proxy/1.0.0/org.apache.aries.proxy-1.0.0.jar
> >  -> mvn:org.apache.aries.proxy/org.apache.aries.proxy/1.0.0 : 89265
> > bytes @ [ 89265kBps ]
> >  -> Resolved (org.apache.aries:org.apache.aries.util:jar:1.0.0) as
> >
> /Users/kjellski/.m2/repository/org/apache/aries/org.apache.aries.util/1.0.0/org.apache.aries.util-1.0.0.jar
> >  -> mvn:org.apache.aries/org.apache.aries.util/1.0.0 : 108826 bytes @
> > [ 108826kBps ]
> >  -> Resolved
> (org.apache.servicemix.bundles:org.apache.servicemix.bundles.asm:jar:3.3_2)
> > as
> /Users/kjellski/.m2/repository/org/apache/servicemix/bundles/org.apache.servicemix.bundles.asm/3.3_2/org.apache.servicemix.bundles.asm-3.3_2.jar
> >  ->
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.asm/3.3_2
> > : 218473 bytes @ [ 218473kBps ]
> >  -> Resolved (org.apache.sshd:sshd-core:jar:0.8.0) as
> >
> /Users/kjellski/.m2/repository/org/apache/sshd/sshd-core/0.8.0/sshd-core-0.8.0.jar
> >  -> mvn:org.apache.sshd/sshd-core/0.8.0 : 376097 bytes @ [ 376097kBps ]
> >  -> Resolved
> (org.apache.karaf.shell:org.apache.karaf.shell.dev:jar:2.3.0)
> > as
> /Users/kjellski/.m2/repository/org/apache/karaf/shell/org.apache.karaf.shell.dev/2.3.0/org.apache.karaf.shell.dev-2.3.0.jar
> >  -> mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.3.0 :
> > 199325 bytes @ [ 199325kBps ]
> >  -> mvn:org.apache.karaf.management/management/2.3.0 : connecting...
> >          ___
> >         /  /
> >        /  / Oops, there has been a problem!
> >       /  /
> >      /__/   org.ops4j.pax.runner.platform.PlatformException:
> > [mvn:org.apache.karaf.management/management/2.3.0] could not be
> > downloaded
> >     ___
> >    /__/     Use --log=debug to see details.
> >
> > myProject]$
> >
> > to reproduce this, you can create a project with pax-create-project
> > and just do nothing else then add the param like this:
> > <param>--profiles=karaf.shell/2.3.0</param> for the
> > pax-provision-plugin
> >
> > My try for the profile is at github here:
> https://gist.github.com/3905879
> >
> > Any hints are very much appreciated, thanks!
>

Mime
View raw message