karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bengt Rodehav <be...@rodehav.com>
Subject Re: Cannot run wrapper on Windows Server 2003 R2
Date Wed, 03 Oct 2012 13:41:17 GMT
Sorry forgot one step....

After I start a clean Karaf I run the command "wrapper:install" - this was
of course the whole purpose :-)

/Bengt

2012/10/3 Bengt Rodehav <bengt@rodehav.com>

> This seems to work:
>
> - Remove the following files:
>     bin\karaf-wrapper.exe
>     lib\wrapper.dll
>     lib\karaf-wrapper.jar
>     lib\karaf-wrapper-main.jar
>
> - Start a clean Karaf from the command line (karaf clean). If I don't make
> a clean start then the previous wrapper files will remain.
>
> - Terminate Karaf
>
> - karaf-service install
>
> /Bengt
>
>
> 2012/10/3 Jean-Baptiste Onofré <jb@nanthrax.net>
>
>> I gonna check but the wrapper should check the platform.
>>
>> Regards
>> JB
>>
>>
>> On 10/03/2012 02:55 PM, Bengt Rodehav wrote:
>>
>>> Thanks for your reply JB.
>>>
>>> Yes, it's a 32 bit platform.
>>>
>>> I just tried on a Windows XP Professional 2002 SP3 (also 32 bit) which
>>> gives me a similar error message:
>>>
>>> "...\apache-karaf-2.2.8\bin\**karaf-wrapper.exe is not a valid Win32
>>> application"
>>>
>>> So, I guess the karaf-wrapper.exe that I'm using requires 64 bit
>>> Windows? Is there a workaround?
>>>
>>> /Bengt
>>>
>>> 2012/10/3 Jean-Baptiste Onofré <jb@nanthrax.net <mailto:jb@nanthrax.net
>>> >>
>>>
>>>
>>>     Hi Bengt,
>>>
>>>     is it a 64bits or 32bits platform ?
>>>
>>>     Regards
>>>     JB
>>>
>>>
>>>     On 10/03/2012 02:42 PM, Bengt Rodehav wrote:
>>>
>>>         I've recently upgraded from Karaf 2.2.5 to Karaf 2.2.8. I've been
>>>         testing mostly on Windows 7 and I'm now trying to install on the
>>>         customer's test system which is running Windows Server 2003 R2.
>>>
>>>         I run the following command: bin\karaf-service.bat install
>>>
>>>         and I get the following error message:
>>>
>>>         "The image file ....\apache-karaf-2.2.8\bin\__**
>>> karaf-wrapper.exe
>>>
>>>         is valid,
>>>         but is for a machine type other than the current machine."
>>>
>>>         What is happening? Has anyone else had this problem?
>>>
>>>         /Bengt
>>>
>>>
>>>     --
>>>     Jean-Baptiste Onofré
>>>     jbonofre@apache.org <mailto:jbonofre@apache.org>
>>>
>>>     http://blog.nanthrax.net
>>>     Talend - http://www.talend.com
>>>
>>>
>>>
>> --
>> Jean-Baptiste Onofré
>> jbonofre@apache.org
>> http://blog.nanthrax.net
>> Talend - http://www.talend.com
>>
>
>

Mime
View raw message