karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Error in starting Karaf with EIK from Eclipse
Date Mon, 01 Oct 2012 08:00:18 GMT
Hi,

we have an issue on trunk build right now. It should be fixed this 
afternoon.

Regards
JB

On 10/01/2012 08:37 AM, PJR69 wrote:
> I'm trying to run Karaf (standalone 2.2.9 or from ServiceMix) from Eclipse
> using exactly the instructions provided on the Wiki.
>
> However, then starting Karaf runtime (just trying to start by running Karaf
> console, no PDE-projects at this moment), I get this error:
> ------------------------
> org.osgi.framework.BundleException: Invalid manifest header Export-Package:
> "org.eclipse.osgi.event;version="1.0",org.eclipse.osgi.framework.console;version="1.1",org.eclipse.osgi.framework.eventmgr;version="1.2",org.eclipse.osgi.framework.log;version="1.0",org.eclipse.osgi.launch;
> version="1.0",org.eclipse.osgi.service.datalocation;version="1.3",org.eclipse.osgi.service.debug;version="1.2",org.eclipse.osgi.service.environment;version="1.3",org.eclipse.osgi.service.localization;version="1.1",org.eclipse.osgi.service.pluginconversion;version="1.0",org.eclipse.osgi.service.resolver;version="1.4",org.eclipse.osgi.service.runnable;version="1.1",org.eclipse.osgi.service.security;
> version="1.0",org.eclipse.osgi.service.urlconversion;version="1.0",org.eclipse.osgi.signedcontent;
> version="1.0",org.eclipse.osgi.storagemanager;version="1.0",org.eclipse.osgi.util;version="1.1",org.osgi.framework;version="1.5",org.osgi.framework.launch;
> version="1.0",org.osgi.framework.hooks.service;
> version="1.0",org.osgi.service.condpermadmin;version="1.1",org.osgi.service.framework;
> version="1.0";
> x-internal:=true,org.osgi.service.packageadmin;version="1.2",org.osgi.service.permissionadmin;version="1.2",org.osgi.service.startlevel;version="1.1",org.osgi.service.url;version="1.0",org.osgi.util.tracker;version="1.4.0",org.osgi.util.tracker;version="1.4.2",org.eclipse.core.runtime.adaptor;x-friends:="org.eclipse.core.runtime",org.eclipse.core.runtime.internal.adaptor;x-internal:=true,org.eclipse.core.runtime.internal.stats;x-friends:="org.eclipse.core.runtime",org.eclipse.osgi.baseadaptor;x-internal:=true,org.eclipse.osgi.baseadaptor.bundlefile;x-internal:=true,org.eclipse.osgi.baseadaptor.hooks;x-internal:=true,org.eclipse.osgi.baseadaptor.loader;x-internal:=true,org.eclipse.osgi.framework.adaptor;x-internal:=true,org.eclipse.osgi.framework.debug;x-internal:=true,org.eclipse.osgi.framework.internal.core;x-internal:=true,org.eclipse.osgi.framework.internal.protocol;x-internal:=true,org.eclipse.osgi.framework.internal.protocol.bundleentry;x-internal:=true,org.eclipse.osgi.framewo
rk.internal.protocol.bundleresource;x-internal:=true,org.eclipse.osgi.framework.internal.protocol.reference;x-internal:=true,org.eclipse.osgi.framework.internal.reliablefile;x-internal:=true,org.eclipse.osgi.framework.util;x-internal:=true,org.eclipse.osgi.internal.baseadaptor;x-internal:=true,org.eclipse.osgi.internal.composite;
> x-internal:=true,org.eclipse.osgi.internal.loader;x-internal:=true,org.eclipse.osgi.internal.loader.buddy;
> x-internal:=true,org.eclipse.osgi.internal.module;x-internal:=true,org.eclipse.osgi.internal.profile;x-internal:=true,org.eclipse.osgi.internal.resolver;x-internal:=true,org.eclipse.osgi.internal.serviceregistry;
> x-internal:=true,org.eclipse.osgi.internal.permadmin;x-internal:=true,org.eclipse.osgi.internal.provisional.service.security;
> x-friends:="org.eclipse.equinox.security.ui";version="1.0.0",org.eclipse.osgi.internal.provisional.verifier;x-friends:="org.eclipse.update.core,org.eclipse.ui.workbench,org.eclipse.equinox.p2.artifact.repository",org.eclipse.osgi.internal.service.security;x-friends:="org.eclipse.equinox.security.ui",org.eclipse.osgi.internal.signedcontent;
> x-internal:=true,org.eclipse.osgi.service.internal.composite;
> x-internal:=true, org.osgi.framework; version=1.5.0,
> org.osgi.framework.launch; version=1.0.0, org.osgi.framework.hooks.service;
> version=1.0.0, org.osgi.service.packageadmin; version=1.2.0,
> org.osgi.service.startlevel; version=1.1.0, org.osgi.service.url;
> version=1.0.0, org.osgi.util.tracker; version=1.4.0,
> org.apache.karaf.jaas.boot; version=2.2.4, org.apache.karaf.version;
> version=2.2.4, "
> 	at
> org.eclipse.osgi.util.ManifestElement.parseHeader(ManifestElement.java:349)
> 	at
> org.eclipse.osgi.internal.resolver.StateBuilder.validateHeaders(StateBuilder.java:189)
> 	at
> org.eclipse.osgi.internal.resolver.StateBuilder.createBundleDescription(StateBuilder.java:50)
> 	at
> org.eclipse.osgi.internal.resolver.StateObjectFactoryImpl.createBundleDescription(StateObjectFactoryImpl.java:32)
> 	at
> org.eclipse.osgi.framework.internal.core.PackageAdminImpl.checkSystemBundle(PackageAdminImpl.java:674)
> 	at
> org.eclipse.osgi.framework.internal.core.PackageAdminImpl.setResolvedBundles(PackageAdminImpl.java:652)
> 	at
> org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:65)
> 	at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
> 	at java.security.AccessController.doPrivileged(Native Method)
> 	at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
> 	at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
> 	at
> org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:207)
> 	at
> org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:654)
> 	at
> org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:298)
> 	at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> 	at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> 	at java.lang.reflect.Method.invoke(Method.java:601)
> 	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
> 	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
> 	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
> 	at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
> An error has occurred. See the log file
> ----
>
> Any ideas how to resolve this?
>
>
>
> --
> View this message in context: http://karaf.922171.n3.nabble.com/Error-in-starting-Karaf-with-EIK-from-Eclipse-tp4026198.html
> Sent from the Karaf - User mailing list archive at Nabble.com.
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message