karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Tran <dant...@gmail.com>
Subject Re: Unable to autostart my KAR under deploy directory
Date Fri, 27 Jan 2012 07:36:44 GMT
my boot feature's bundles starts at 63, my kar feature's bundle start
at 64 and up

-D

On Thu, Jan 26, 2012 at 11:28 PM, Jean-Baptiste Onofré <jb@nanthrax.net> wrote:
> What's the start-level of your features ?
>
> Regards
> JB
>
>
> On 01/27/2012 08:17 AM, Dan Tran wrote:
>>
>> Look like I am NOT able to get my boot feature and anther feature
>> under deploy booting up together.  if I drop the kar file to deploy
>> folder  after karaf started, then it works. Will need to dig deeper.
>>
>> thanks
>>
>> -Dan
>>
>> On Thu, Jan 26, 2012 at 10:29 PM, Jean-Baptiste Onofré<jb@nanthrax.net>
>>  wrote:
>>>
>>> Hi Dan,
>>>
>>> starting from Karaf 2.2.4, the KarDeployer is looking for features.xml in
>>> the KAR and install all features.
>>>
>>> Could you check in the log file ?
>>>
>>> Regards
>>> JB
>>>
>>>
>>> On 01/27/2012 06:31 AM, Dan Tran wrote:
>>>>
>>>>
>>>> Hi,
>>>>
>>>> I have an impression karaf 2.2.5 would autostart any kar file in its
>>>> deploy directory.  In my case, my's feature just sits under
>>>> 'uninstall' state?
>>>>
>>>> am I missing something?
>>>>
>>>> Thanks
>>>>
>>>> -D
>>>
>>>
>>>
>>> --
>>> Jean-Baptiste Onofré
>>> jbonofre@apache.org
>>> http://blog.nanthrax.net
>>> Talend - http://www.talend.com
>
>
> --
> Jean-Baptiste Onofré
> jbonofre@apache.org
> http://blog.nanthrax.net
> Talend - http://www.talend.com

Mime
View raw message