karaf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivanhoe Abrahams <ivanhoeabrah...@gmail.com>
Subject adding aries jndi, transaction and persistence features to my instance
Date Sun, 02 Jan 2011 09:55:33 GMT
Hi

I am in the process of adding aries transaction, jndi and persistence to my
karaf instance

To achieve this I downloaded the aries source code and built it locally.
I also downloaded the enterprise-2.1.99-SNAPSHOT-features features file and
am trying to run the  features:install transaction command (btw I also tried
persistence and jndi)
However if I do the above I get the following error

karaf@root> features:install transaction
Error executing command: Invalid value: (obr)))

I then went and changed the feature xml file and removed the following
attribute .... resolver='(obr)'

After that change I get the following error

karaf@root> features:install transaction
Error executing command: Could not start bundle
mvn:org.apache.aries.transaction/org.apache.aries.transaction.blueprint/0.3-SNAPSHOT
in feature(s) : Unresolved constraint in bundle org.apache.aries.tr
ansaction.blueprint [187]: Unable to resolve 187.0: missing requirement
[187.0] package;
(&(package=org.apache.aries.blueprint)(version>=0.3.0)(!(version>=1.0.0)))

I am assuming that this is because the aries version that is bundled with
karaf is only at version 0.2.0 incubating

So my question is
Is it possible to upgrade the karaf-bundled version of aries to 0.3.0? I
wouldnt want to have both the old version and 0.3.0 installed, that seems
unneccessary
otherwise, what do others do to install the latest enterprise aries
features?

Thankyou in advance

Regards
Ivanhoe

Mime
View raw message