karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amichai Rothman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-6210) NoClassDefFoundError: org/apache/karaf/shell/api/action/Action when starting Karaf
Date Mon, 29 Apr 2019 12:17:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-6210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16829195#comment-16829195
] 

Amichai Rothman commented on KARAF-6210:
----------------------------------------

ASUS ZenBook UX331u

Core i7-8550U, 16GB RAM

Windows 10 64-bit version 1809 (OS Build 17763.437)

Oracle JDK 1.8.0_202

Stock Karaf 4.2.5 (only change is setting framework to equinox)

Tried starting karaf both from cmd via batch file, and from git bash via sh file, same result
in both.

As I mentioned, I've seen this happen on Linux once as well (on same hardware iirc, same JDK),
but it's rare. On Window it's 100% reproducible so far.

Never saw this issue in Karaf 4.2.3 or earlier.

Any other info that might be useful? Or something you'd like me to test?

 

> NoClassDefFoundError: org/apache/karaf/shell/api/action/Action when starting Karaf
> ----------------------------------------------------------------------------------
>
>                 Key: KARAF-6210
>                 URL: https://issues.apache.org/jira/browse/KARAF-6210
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf
>    Affects Versions: 4.2.4
>         Environment: Stock Karaf 4.2.4 on Windows 10 with latest Oracle JDK 8.
>            Reporter: Amichai Rothman
>            Assignee: Jean-Baptiste Onofré
>            Priority: Major
>
> When starting karaf using equinox and some bundle in the deploy folder, many shell commands
(such as bundle:* and others) are not recognized, and the log shows NoClassDefFoundError:
org/apache/karaf/shell/api/action/Action. Some commands don't work, but others (e.g. shell:*)
do.
> This happens consistently on Windows 10, but not on Linux, not sure why.
>  
> Steps to recreate:
> 1. Extract stock Karaf 4.2.4.
> 2. In etc/config.properties change karaf.framework=felix to karaf.framework=equinox.
> 3. Place org.apache.aries.transaction.blueprint-2.2.0.jar (from maven) in deploy folder.
This is not the only bundle it happens with, just a public one I found for this example. From
several I tried, some recreated the issue and some did not. The bundle is not resolved due
to missing dependencies.
> 4. Start Karaf.
> 5. Try to run bundle:list and it'll say command not found. Or look at the karaf log and
see "java.lang.NoClassDefFoundError: org/apache/karaf/shell/api/action/Action". Use shell
completion to see that some commands are available but others are not.
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message