karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-6199) Upgrade Hibernate feature to work with Java 11
Date Thu, 11 Apr 2019 14:10:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-6199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16815440#comment-16815440
] 

Jean-Baptiste Onofré commented on KARAF-6199:
---------------------------------------------

I'm testing the upgrade to Hibernate 5.4.2.Final (and move 5.2.x to the enterprise-legacy
features).

> Upgrade Hibernate feature to work with Java 11
> ----------------------------------------------
>
>                 Key: KARAF-6199
>                 URL: https://issues.apache.org/jira/browse/KARAF-6199
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>            Priority: Major
>             Fix For: 4.3.0, 4.2.5
>
>
> Karaf comes with hibernate 5.2.17 which intalls
> org.javassist/javassist/3.22.0-GA which is not Java 11 capable
> https://github.com/jboss-javassist/javassist/issues/194). 
> When I manually change 3.22.0-GA to 3.23.1-GA, everything works as expected.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message