karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-5641) Karaf boot scripts need to deal with JDK10 version patterns
Date Wed, 14 Mar 2018 09:43:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-5641?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16398337#comment-16398337
] 

ASF subversion and git services commented on KARAF-5641:
--------------------------------------------------------

Commit ad07ce64d9d09bc206f819049dd453f3550fafd7 in karaf's branch refs/heads/master from [~ffang]
[ https://gitbox.apache.org/repos/asf?p=karaf.git;h=ad07ce6 ]

[KARAF-5641]ensure Karaf kit can run with java10


> Karaf boot scripts need to deal with JDK10 version patterns
> -----------------------------------------------------------
>
>                 Key: KARAF-5641
>                 URL: https://issues.apache.org/jira/browse/KARAF-5641
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-core
>    Affects Versions: 4.2.0.M2
>            Reporter: Sanne Grinovero
>            Assignee: Guillaume Nodet
>            Priority: Major
>             Fix For: 4.2.0
>
>
> The {{checkJvmVersion()}} function in the {{/bin/inc}} script of the distribution is
not dealing with the new output of {{java -version}} of JDK10 (and later?).
> The {{VERSION}} variable is left undefined, which then has the main bootscript to not
set the Jigsaw modules correctly (the various JVM flags which need to be enabled since Java
9).
> This is a blocker to use Karaf on Java 10, which is already in candidate release. I don't
think much else is changed compared to Java 9 so it would be great to sort this.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message