karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Resolved] (KARAF-5590) SSHD client authentication fails with JDK 1.8.0_161
Date Sun, 11 Feb 2018 19:31:00 GMT

     [ https://issues.apache.org/jira/browse/KARAF-5590?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré resolved KARAF-5590.
-----------------------------------------
       Resolution: Cannot Reproduce
    Fix Version/s:     (was: 4.1.5)
                       (was: 4.2.0)
                       (was: 4.0.11)

I'm not able to reproduce with JDK 1.8.0_161 or 1.8.0_162. I tried a SNAPSHOT version compiled
locally or with 4.1.4 from website (so compiled with another JDK).

> SSHD client authentication fails with JDK 1.8.0_161
> ---------------------------------------------------
>
>                 Key: KARAF-5590
>                 URL: https://issues.apache.org/jira/browse/KARAF-5590
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-shell
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>            Priority: Blocker
>
> After upgrading to JDK 1.8.0_161, the {{bin/client}} fails to connect with:
> {code}
> "java.security.InvalidKeyException: The security strength of SHA-1 digest algorithm is
not sufficient for this key size"
> {code}
> It's related to oracle changed the defaults for DSA keys in jarsigner and keytool in
jdk 1.8.151, see http://www.oracle.com/technetwork/java/javase/8u151-relnotes-3850493.html
> I think we can workaround by providing a key to {{bin/client}} and overriding the one
in {{etc/org.apache.karaf.shell.cfg}} configuration file.
> At least, it has to be tested.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message