karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Grzegorz Grzybek (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-4506) karaf-maven-plugin can not find sub feature with SNAPSHOT in version
Date Wed, 06 Dec 2017 15:17:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4506?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16280298#comment-16280298
] 

Grzegorz Grzybek commented on KARAF-4506:
-----------------------------------------

Karaf 4.2 has much better support for _cleaning_ versions (convering any Maven version into
proper OSGi version). With 4.0.x I suggest using proper OSGi versions as Maven ones... The
mechanisms for dealing with versions were changed considerably after 4.0.x, so it's not a
trivial backport.

[~gnt], [~jbonofre], [~chris@die-schneider.net], what do you think?

> karaf-maven-plugin can not find sub feature with SNAPSHOT in version
> --------------------------------------------------------------------
>
>                 Key: KARAF-4506
>                 URL: https://issues.apache.org/jira/browse/KARAF-4506
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-tooling
>    Affects Versions: 4.0.5
>            Reporter: Oleksandr Maksymenko
>            Assignee: Grzegorz Grzybek
>         Attachments: example.zip
>
>
> I have very simple feature file
> {noformat}
> <features  name="bug-1.0-SNAPSHOT">
>     <feature name="bug-submodule" version="1.0-SNAPSHOT">
>     </feature>
>     <feature name="bug-module" version="1.0-SNAPSHOT">
>         <feature version="1.0-SNAPSHOT">bug-submodule</feature>
>     </feature>
> </features>
> {noformat}
> when I try to execute goal karaf-assembly with boot feature bug-module I getting
> {noformat}
> [ERROR] Failed to execute goal org.apache.karaf.tooling:karaf-maven-plugin:4.0.5:assembly
(default-assembly) on project test-a-2: Unable to build assembly: Could not find matching
feature for bug-submodule/1.0-SNAPSHOT -> [Help 1]
> {noformat}
> Same build worked well with version 4.0.2
> In example.zip I prepared files to reproduce this problem 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message