karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-5470) Karaf fails build with Java 9.0.1
Date Thu, 09 Nov 2017 09:25:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-5470?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16245408#comment-16245408
] 

ASF subversion and git services commented on KARAF-5470:
--------------------------------------------------------

Commit 4cd28b2737b4763faeddea13f7661064fa1d41d0 in karaf's branch refs/heads/master from [~jbonofre]
[ https://gitbox.apache.org/repos/asf?p=karaf.git;h=4cd28b2 ]

[KARAF-5470] Extend enforce JDK version range to include Java 9


> Karaf fails build with Java 9.0.1
> ---------------------------------
>
>                 Key: KARAF-5470
>                 URL: https://issues.apache.org/jira/browse/KARAF-5470
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.2.0.M1
>            Reporter: David Otasek
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.2.0
>
>
> When attempting to build Karaf with Java build 9.0.1+11, it fails with the following
warning:
> [WARNING] Rule 1: org.apache.maven.plugins.enforcer.RequireJavaVersion failed with message:
> Detected JDK Version: 9.0.1 is not in the allowed range [1.8,9].



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message