karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-5470) Karaf fails build with Java 9.0.1
Date Wed, 08 Nov 2017 20:03:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-5470?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16244635#comment-16244635
] 

Jean-Baptiste Onofré commented on KARAF-5470:
---------------------------------------------

Thanks. I'm extending the enforcer rule.

> Karaf fails build with Java 9.0.1
> ---------------------------------
>
>                 Key: KARAF-5470
>                 URL: https://issues.apache.org/jira/browse/KARAF-5470
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.2.0.M1
>            Reporter: David Otasek
>
> When attempting to build Karaf with Java build 9.0.1+11, it fails with the following
warning:
> [WARNING] Rule 1: org.apache.maven.plugins.enforcer.RequireJavaVersion failed with message:
> Detected JDK Version: 9.0.1 is not in the allowed range [1.8,9].



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message