karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paolo Antinori (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-5415) Issue with feature resolution (CXF related)
Date Tue, 10 Oct 2017 11:25:00 GMT
Paolo Antinori created KARAF-5415:
-------------------------------------

             Summary: Issue with feature resolution (CXF related)
                 Key: KARAF-5415
                 URL: https://issues.apache.org/jira/browse/KARAF-5415
             Project: Karaf
          Issue Type: Bug
    Affects Versions: 4.1.2
            Reporter: Paolo Antinori


Hi, I am facing an odd behavior I cannot explain, with the feature resolution logic.

I suspect a bug

In the scenario that I'm going to describe here, I end up with a version of jetty that I wouldn't
expect to see installed.

0. create a new features descriptor on the filesystem:
{code}
cat >> /tmp/features.xml <<"EOF"
<?xml version="1.0" encoding="UTF-8"?>
<features xmlns="http://karaf.apache.org/xmlns/features/v1.0.0" name="cxf-test">
    <feature name="test1" version="1.0">
       <feature version="[7,10)">jetty</feature> 
    </feature>
    <feature name="test2" version="1.0">
       <feature version="[3,4)">cxf-http</feature>
    </feature>
    <!-- include both -->
    <feature name="test3" version="1.0">
       <feature version="[3,4)">cxf-http</feature>
       <feature version="[7,10)">jetty</feature> 
    </feature>
</features>
EOF
{code}

1. start a clean karaf 4.1.2
2. enable cxf repo: {{repo-add cxf 3.1.12}}
3. enable custom repo: {{feature:repo-add file:///tmp/features.xml}}
4. now the test, compare the outcome of the installation of the 3 features:
{code}
karaf@root()> feature:install test1
karaf@root()> la -l | grep -i jetty-all
# empty

karaf@root()> feature:uninstall test1

karaf@root()> feature:install test2
karaf@root()> la -l | grep -i jetty-all
# empty

karaf@root()> feature:uninstall test2

karaf@root()> feature:install test3
karaf@root()> la -l | grep -i jetty-all                                               
                                                                      
142 │ Active   │  30 │ 8.1.14.v20131031 │ mvn:org.eclipse.jetty.aggregate/jetty-all-server/8.1.14.v20131031
# installs something from jetty 8 ???
{code}

So far I have not been able to understand in debug, where the error occurr or what's causing
it.







--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message