karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Schneider (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-5300) FeaturesService should use more specific classes for model
Date Wed, 09 Aug 2017 15:38:00 GMT
Christian Schneider created KARAF-5300:
------------------------------------------

             Summary: FeaturesService should use more specific classes for model
                 Key: KARAF-5300
                 URL: https://issues.apache.org/jira/browse/KARAF-5300
             Project: Karaf
          Issue Type: Bug
          Components: karaf-feature
            Reporter: Christian Schneider
            Assignee: Christian Schneider


Currently the feature service uses strings for many different purposes:
- feature name
- feature name glob
- feature version
- feature version range

It is difficult to tell what purpose such a string has.

I would like to create a type FeatureReq(name, VersionRange) that describes better what we
do. This should make the code a lot easier to understand.

Ideally we would also reflect this in the service interface but the stay backwards compatbile
I will only use the new types internally.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message