karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Hong (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-5103) Quick start fails at the step "feature:install camel-spring"
Date Thu, 10 Aug 2017 04:02:00 GMT

    [ https://issues.apache.org/jira/browse/KARAF-5103?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16121024#comment-16121024
] 

Bob Hong commented on KARAF-5103:
---------------------------------

I don't believe this is fixed.  The Quick Start URL http://karaf.apache.org/manual/latest/#_deploy_a_sample_application
still references 2.15.2.

I am able to add the repo using 2.18.4 as suggested in the prior comment and install the camel-spring
feature, but get errors installing the bundle using 2.18.4 or 2.15.2: 

karaf@root()> feature:repo-add camel 2.18.4
Adding feature url mvn:org.apache.camel.karaf/apache-camel/2.18.4/xml/features
karaf@root()> feature:install camel-spring
karaf@root()> bundle:install -s mvn:org.apache.camel/camel-example-osgi/2.18.4
Bundle IDs: 
Error executing command: Error installing bundles:
	Unable to install bundle mvn:org.apache.camel/camel-example-osgi/2.18.4: org.osgi.framework.BundleException:
Unable to cache bundle: mvn:org.apache.camel/camel-example-osgi/2.18.4
karaf@root()> bundle:install -s mvn:org.apache.camel/camel-example-osgi/2.15.2        
                                                              
Bundle ID: 69
Error executing command: Error installing bundles:
	Unable to start bundle mvn:org.apache.camel/camel-example-osgi/2.15.2: org.osgi.framework.BundleException:
Unable to resolve camel-example-osgi [69](R 69.0): missing requirement [camel-example-osgi
[69](R 69.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.builder)(version>=2.15.0)(!(version>=2.16.0)))
Unresolved requirements: [[camel-example-osgi [69](R 69.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.builder)(version>=2.15.0)(!(version>=2.16.0)))]


> Quick start fails at the step "feature:install camel-spring"
> ------------------------------------------------------------
>
>                 Key: KARAF-5103
>                 URL: https://issues.apache.org/jira/browse/KARAF-5103
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.1.1
>         Environment: Ubuntu 14.04
>            Reporter: Mike Fogg
>            Assignee: Christian Schneider
>             Fix For: 4.2.0, 4.1.2
>
>
> The quick start results in an error when entering the command to install camel-spring.
> karaf@root()> feature:install camel-spring
> Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=camel-spring; type=karaf.feature; version="[2.15.2,2.15.2]"; filter:="(&(osgi.identity=camel-spring)(type=karaf.feature)(version>=2.15.2)(version<=2.15.2))"
[caused by: Unable to resolve camel-spring/2.15.2: missing requirement [camel-spring/2.15.2]
osgi.identity; osgi.identity=spring; type=karaf.feature; version="[3.2.0,4.0.0)"]
> It sounds like this is related to KARAF-4730, however since this is the first thing I
have tried after installing and is my introduction to Karaf (as it would be presumably for
anyone going through the Quick Start), I don't know how I would go about removing the filter
from the camel-spring dependency in order to install it.  Considering this is a quick start,
I probably shouldn't have to do anything that isn't spelled out in the instructions.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message